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INTRODUCTION

 1.1  Documents Purpose and Credits

This document was produced using initial work by Bob Woltz.  The Quick Start Guide to LibreCAD by Jasleen Kaur 
(January 2014) is beneficial to download.  Refer to the section named LibreCAD References for further information.  The
additions and amendments here are not the work of anyone with programming experience and I have little LibreCAD 
experience and this document may have many errors.  It has been made with a wholehearted effort to produce a 
workable desktop reference for those with little LibreCAD experience and are trying to learn how to use it; like I am. 
At times a description or clarification has been added to the notes, that may not be strictly necessary, but we hope is an 
aid to assist those where the English language is not their first language.  

I believe the size of the document shows the need for a manual and I hope that others can point out errors and 
refinements as necessary so that further amendments can be produced.    More work can always go into elaborating and 
checking; it becomes the law of diminishing returns, so here it is but imperfect.  Illustrations are minimal because you will 
have the screen in front of you as a constant reference and this document is big enough to print out as it is.  Much of the 
material is based on the LibreCAD Forum and thanks is due to the many persons who took the time to ask for assistance.
Searching through the mass of documentation I found many points and features that I was unaware of and I will be 
surprised if many users of LibreCAD do not experience the same feeling.  Thanks to all who spent the time and effort to 
put the LibreCAD program together and continue to support it.

This document with its content is made available under Creative Commons Attribution Share Alike.
  
If the document name above with year, month and day format is also at the start of the file name (shown at the top of the 
screen) this will file this document in date order within any LibreCAD folder. This permits any amendment with a later date
to be easily found.

The document was formulated in Apache Open Office version 4.1.3 (2016).  It could be saved into Microsoft Word 
97/2000/XP (.doc format) but perhaps with some lose of formating.  Alternatively convert into a PDF, although that may 
not be desirable.
.
1.2  Description of Apache Open Office Functions:

To be taken to a numbered page of this document:  Position your curser over the page number in the Contents Section 
(below).  Use keyboard shortform Ctrl and left mouse click when the curser changes into 'hand symbol' when you are 
pointing at the desired page number.  The document then will open to the required page of the this document. 

To navigate around this document: press the F5 key (generally in the top row of the keyboard) OR the small 'compass' 
icon (alongside the 'binoculars' icon) on the tool bar under the Menu bar and a small window opens.  
This window can be moved (dragged) on to a little used part of your screen for future use.  Repeat the F5 key command 
to remove the active window from view.  In the small window if you double left mouse click on Headings Contents 
Section this document will go to that location (or any other section you double click on) after you scroll down and find its 
location. Or you can scroll down using the scroll bars in the auxiliary window until you find the section you are after and 
then double click that section heading. 

To find a word in this document click on the 'binoculars' icon (on tool icons below the Menu bar) with the tool-tip  'Find and
Replace' (Ctrl+F) type a word in the Search for pane and click on the Find radio button.   A small window opens asking 
basically 'do you want to continue' if you click on 'yes' button the 'Find and Replace' window opens.  Now every time you 
press the 'Find' button it will open to the next usage of the word in the document.  For example:  If you want to find out 
about Trim, type the word into the Search area of the 'Find and Replace' window that opens when you click on the 
'binoculars' icon (remember it is Apache Open Office) and continually press 'Find' to progressively work through this 
document so you can read the information.  The other way to consider only 'headings' is as mentioned in the previous 
paragraph.

Be careful using the Scroll bars to move through the document as the size of this Manual may cause the program to 
'crash'.  It may be preferable to use the wheel mouse or auxiliary screen as noted above.

To learn how to modify and add more to this document; refer to the section How to Modify the LibreCAD Users Manual
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OVERVIEW To LibreCAD

Version: 2.1.3 (Screen appearance may be different if using a different version) 
Compiler: GNU GCC 4.9.1
Version Compiled on: Sep 23 2016

When you open the program the last title word to the right hand side is Help click on this word and the option About 
appears.  Click on this word and you will be able to compare your program with the one that was used to compile this 
manual.  If older or newer there is likely differences.  Please take this into consideration.  Also:

 Check the contents pages of this document to get and overview of the areas that interest you and where they are 
in this document.

 This document is designed to be printed out as a on-desk reference and to be modified by you to correct errors 
and enlarge as your experience grows.

 It is recommended that you pencil in changes; and rub out obsolete information, so that you have a record of 
what you have changed. 

 1.1   Program Features

From LibreCAD wiki
Save/Open: DXF, CXF, LFF
Import: DWG, JWW, SHP, PIC
Export: SVG, PDF, ICO, JPG, PNG, DDS, TIF, BMP, Others…
Tool Categories: line, polyline, spline, circle, ellipse, text, dimension
Drawing: advanced snapping system, blocks, hatches, layers, templates, 2D iso/ortho
UI: custom toolbars and menus, movable widgets, commandline,
full screen
Extension: plugin system, style sheets (appearance), opensource

Retrieved from "http://wiki.librecad.org/index.php?title=Features&oldid=2158"
This page was last modified on 25 February 2017, at 02:52.

 1.2 How to Start Program:

Use file explorer to find: c:\Program Files(x86)\LibreCAD.exe
Then right click and pin it to the task bar.
The main window appears on screen, showing the GUI (the Graphical User Interface).  Depending on your preferred 
operating system the screen appearance may differ from what is shown in this manual.

 1.3 Initial Settings:

Set Your Default Units to Save Time!
When you download the PROGRAM and click to open and run it you will find a on-screen box opens in the black and 
apple green font reading LibreCAD. “Welcome to LibreCAD  Please choose the unit you want to use for new drawings 
and your preferred language.  You can change these settings later in the Options > Dialog of LibreCAD.”  
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Information seen on screen under help.

DEFAULT Set your CHOICE (mine is)

Default Unit:  Foot Default Unit:  Millimetres

GUI language: English GUI language: English (Australia)

Command language: English Command language: English (Australia)

 1.4 Terminology:

Lines, circles etc are called entities.  Entities are often connected with a snap that fixes the entity to a position on an other
entity or a grid intersection.  Such a fixed point – a grid intersection is fixed in space with what a called x,y and z 
coordinates.  These coordinates can be plus or minus numbers that increase from a centre point.  
Opening a  Menu Toolbar, such as Tools opens a Selection menu and these often have flyouts, an attached toolbar with 
additional buttons. The presence of  a flyout is indicated by a  ► symbol to the right of the toolbar name.  Move your 
curser in the direction indicated and the flyout will appear on screen. 

 1.5 Initial Drawing Method:

Drawing in LibreCAD can be done in two ways:

1. Drawing with mouse-clicking
2. Drawing with the keyboard

When drawing with the mouse, you just click on one of the icons from the Menu bar > Tools > (select tool from flyout) and 
click with the left mouse button on to the Drawing Area.  (Refer to the subsection Mouse Settings).  Undoing the last 
action is done by pressing the right mouse button.  This completes the command.  Then press the Undo button (1st row of 
icons and 2nd icon from the left).The right mouse button as well as the Esc (the Escape button) can be used to end the 
draw procedure.  The Escape button on the keyboard, is generally located at the top LH corner of the keyboard.  To Zoom
you can spin the wheel mouse away from you to zoom in or towards you to zoom out.  To Pan  without zooming press the
wheel down without spinning it and move the mouse in the direction you want to see more.  The steps to draw with your 
keyboard are the same as the steps taken while drawing with the mouse.  The difference is, you have to type the 
commands/instructions in to the command line.  The use of the command line is described elsewhere. 
  

 If you don't know what to do in the next step, when drawing, you may want to look for a comment in the command
line and check for changes (that indicate further input is required in the Tool Options bar.  The tool Option bar is, 
located just above the Drawing Area. (The Tool Options bar and Drawing Area are described below under 
Application Screen Description).

 When I click to a line or any object it is not selected. Then please try the Selection Pointer found at: Main menu 
bar > Edit > Selection Pointer (1st on flyout) and pick and entity or window multiple objects.

 1.6 Abbreviations used in these notes:

BTM – Bottom; LHS – Left Hand Side;  TLHS – Top Left Hand Side; RHS – Right Hand Side; TRHS – Top Right 
Hand side;

Throughout the manual -  Please read the paragraph first; before working through the action the paragraph 
describes.

 1.7 Mouse Settings:

 A 'mouse' can have two or more buttons.  The left mouse button  is used to choose commands and toolbar 
buttons and to pick points on your drawing.  It is sometimes called the pick button. 

 The right button usually opens a shortcut menu or completes a command.
 A 'wheelmouse' has a wheel between the two buttons set it so that when your finger moves forward towards the 

screen and rotates the wheel you zoom into the drawing and when the wheel and finger rotates away from the 
screen zoom out of the drawing.  Note that when zooming in or out if you point the curser in the direction of an  
object that object will be kept near the centre of the screen as you move zoom in or out.

 The 'wheelmouse' button held down gives you the option of panning or moving the drawing around.  The curser 
turns into a  'hand symbol'  and objects out of view can be brought into sight.

 1.8 Application -  Screen Description:
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For detailed information refer to (http://wiki librecad.org/index.php/LibreCAD_Quick_Start_Guide/LibreCAD_Screen)

Above the Drawing Area

 Go ahead when ready and start up LibreCAD by double clicking on the light green circle icon that is the symbol 
for the program. You will likely find this icon on your Start Page or on your Task bar at the top of you your 
computer screen.  The following descriptions describe each row of icons working from the top of the screen, when
the program opens. At the top of the screen is  the Title Bar where the Drawing title will be shown appears when 
you 'save' the drawing as noted below.  Then is : 

 Application Settings:  On the RHS of the screen at the top are Application (that is LibreCAD ) minimise button; 
Application maximise button; Application Close button; Drawing Close button (a red X).

 Title bar: On opening Program initially will read LibreCAD [Unnamed Document 1] 2 etc.  This description will 
change to the title name of the drawing that you input when you 'save' the drawing.  (refer to Save icon below for 
further information).

Main Menu and Tools

The main menu is at the very top of the window program application.  From the main menu you can reach every 
command, but there are faster ways to do the same job, such as command line and toolbars.

 Menu bar: Below the Title bar there are a number of words making up the Menu Bar that you can click on for pull-
down menus.  Don't select anything from the menus as of yet, we will examine some of the selections as we work
though the manual.  

 On the RHS of the Menu bar are the Drawing minimise button; Drawing maximise button; and Drawing close 
button. 

 What is shown on the Menu Bar may be duplicated on the various Tool bars.  For instance in the Line tool bar on 
the left of the screen.  This may not show on your screen according to the settings at this stage.

Main Tools: Top Toolbars

If you right-click on the icons of the toolbars a selection menu will appear: you can select which toolbars to show.  If you 
locate your curser over the broken horizontal line( ----) at the top of the selection menu you can obtain a copy of the 
related toolbar, this floating toolbar, can be moved to a convenient position on the screen area.

 Pen Selection (Styles) Tool bar: For the changing of entity qualities, this is directly below the Menu Bar on the 
LHS of the screen. Reading: Line colour, Line width and Linetype. 

 Snap Selection Tool bar is on the same row as the Pen Selection Tool bar.
 Tools Options bar: Is the tools located on the second row below the menu bar.  Please note that the 

information on this line changes according to the commands that you input and at times there may be 
information shown here that you need to modify for the program to continue with its response to the 
Command line.

 The Properties window will come apparent on the Drawing Area as needed, and is mentioned here as you may 
wonder where it is.

 Note the Icons below the words of the Menu Bar.  Put your cursor over each icon, by moving your mouse 
without clicking the mouse and the computer program with show a description on screen of what that icon 
does.  These descriptions are called tool tips.

Drawing Area (Model Space) and Auxiliary Window
 The Drawing area is the majority of the screen area with an Auxiliary Window, generally the RHS.  The 

auxiliary window originally in some CAD programs was another ancillary computer screen.  
 Within the Drawing Area is the UCS (User Coordinate System) icon which on my computer is a simple red 

coloured cross this is located at 0,0,0 which is shorthand for describing the location as being x=0, y=0 and 
in 3D drawings z=0.  The UCS can have different appearances and you can change the appearance at 
Menu bar > Options > Application Preferences > Appearance tab.

 The crosshairs  take the the place of the Curser in many functions and this plus the Pickbox can also of 
different appearance and size (plus other options) found at the above location.  I recommend the option 
where they cover the size of the Drawing Area.  

 Now let us consider the Auxiliary Window.  Notice the Command Line at the bottom left hand side of the 
screen or the the bottom right hand side of the screen. 

 If an Auxiliary Window is not visible anywhere; go to the bottom left hand side of the screen with your curser,
right mouse click (assuming you have a 3 button mouse, - refer to mouse settings section) and a small 
window opens up reading Tool bars, Dockwidgets and Status Bar.  In the Dockwidgets ► flyout you will see 
2nd from the top of the list Command Line, ensure this is ticked.  The Command Line will now appear with 
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Library Browser; Block List; Layer List (if these are ticked as well) on the right hand side of the drawing 
area.  You can toggle between the 4 areas by pressing the 'radio buttons' with your curser. The Command 
line is at the top with the Command (input) below.  When the command line (input) is blue coloured it is 
waiting for command input.   Use of this Command Line input is considered in the Command Line section of
this Manual.  Sometimes LibreCAD waits for special input so get into the habit of checking if the program 
wants input from you and has written here a request for direction.  'Comma... stands for Command Line.

 On the 'right-hand side of the LibreCAD drawing window you will notice areas for creating Layers and 
Blocks or whatever else is ticked on the Dockwidget flyout. 

 Scroll bars:  Finally at the bottom of the Drawing Area and the RHS are the scroll bars, that can be used to 
navigate around the Drawing Area, they work similar to a text program slider.  I think you will find the 
wheelmouse superior and more intuitive than scroll bars.   These can be added (ticked) or removed 
(unticked) also at the Menu bar > Options > Application Preferences > Appearance tab.

Below the Drawing Window - Introduction
 Status bar:   This turns on the area at the bottom of the screen and provides information on the current 

'status' of the drawing. For example information on the grid settings.  I leave this On.  
 Command Line is at the bottom right hand side of the screen. If it is not visible go to the bottom left hand 

side of the screen (under the scroll bar location) your curser will now turn into a '4 pointed arrow cross', right
mouse click (assuming you have a 3 button mouse, - refer to mouse settings section) and a small window 
opens up reading Tool Bars, Dockwidgets and Status Bar (shown ticked).  If Status Bar is not ticked this will 
be hidden, tick item.  Ensure you are not in a Command by pressing the keyboard Esc key twice then check 
again to see if the '4 pointed arrow cross' appears.  The command Ctrl+l is mentioned on the small window 
alongside the word Status bar; I could not find any reference to this command as it opens up Layer Settings 
window. 

 In the Dockwidgets ► flyout you will see 2nd from the top of the list Command Line, ensure this is ticked. 
The Command Line will now appear with Library Browser; Block List; Layer List on the right hand side of the
drawing area.  (depending on following description).  You can toggle between the 4 areas by pressing the 
'radio buttons' with your curser. The Command line is at the top with the Command (input) below.  When the
command line is blue coloured it is waiting for command input. 

Below the Drawing Window - Description
 Four tool bars are described first.  As they are available elsewhere (Menu bar > Tools) the Tool tip will only 

be mentioned here.
    
1st Tool bar 2nd Tool bar 3rd Tool bar  4th Tool bar (>>)

Circle + C Polyline Aligned Dimension Move / Copy

Circle 3 Point Add Node Linear Dimension Rotate

Arc Tangential Append Node Horizontal dimension Scale

Spline Delete Node Vertical Dimension Mirror

Spline through Points Delete between two Nodes Radial Dimension Move & Rotate

Freehand Line Trim Segments Diametric Dimension Rotate Two

Create Equidistant Polylines Angular Dimension Revert Direction

Create Polyline … Segments Leader Trim

Trim2

Lengthen

Offset

Bevel

Fillet

Divide

Stretch

Properties

Attributes

Explode Text into Letters (H)
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1st Tool bar 2nd Tool bar 3rd Tool bar  4th Tool bar (>>)

Explode (H)

Delete Selected (H)

Explanation:  (>>) click on to reveal Hidden (H) tool icons on remainder of tool bar.

 On the extreme RH end of the tool bar is the symbol >>; this gives various placement options for your 
toolbars.  The options, which may include more than one being highlighted are: Left; Right; Top; Bottom; 
Floating (i.e. tool pane has no fixed location and can be dragged where desired).

 Absolute zero point, position of curser at UCS (0,0)
 Relative position of curser, to the Absolute position of the UCS (0,0)
 copy of command line information
 Mouse widget (“Tool hint about left/right mouse button actions”  shows the status (function) of the mouse left

and right buttons)
 Selection - number of items selected
 Total length of items selected
 Current drawing layer
 Grid Status e.g. 10/100.  The points of the grid are 10 units apart.  A rectangle of the grid is 100 units wide.
 To enable/disable status bar, go to Menu: View > Status bar.

Inserted  screen-shot illustration of   LibreCAD   Screen as described here

MENU BAR - Description

You will also see icons on the left hand side of the screen and by moving the cursor near each of these icon you will
(generally) note information on their function as well.  We can determine that the first 7 icons are Drawing Icons; the
next two icons draws text and the next draws Dimensions.  The next two icons create Hatch and Insert Images and 
the last 4 icons : Create Block; Points; Scale and the last is Save (which is an image of a floppy disc). 

Going back now to the Menu Bar words each word has a list of options with an additional list as a flyout.  (Open 
'flyout' with additional options by moving cursor over ► symbol to the right hand side of the option; this opens the 
'flyout').  So this row of icons makes up a Drawing Toolbar.   Do not stress about learning this description it will 
become automatic soon.

 If you lose a icon from a tool bar right mouse click on empty space in any tool place to show up CAD tools 
option, that is not in view menu. 
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File (1st Word on Bar)
This area is composed of 12 divisions as follows; with 2 of the sections having additional sub-sections indicated by 
the ► symbol directing you to an attached 'flyout' list.  Many commands have keyboard short-form commands:

 New Drawing; will start a new LibreCAD file document / drawing.
 New from Template;
 Open (Drawing); will open a saved drawing.
 Save;   - To save a current drawing. Has a 'floppy disc' symbol.  Shortform is Ctrl S.  
 Save As; Opens 'Save Drawing As' dialog and gives you file formats to save too.
 Import ► Insert Image;

 Block;
 Export ► Export as MakerCAM SVG;

 Export as PDF;
 Export as Image;

 Print; will open up the print dialog window. 
 Print Preview; opens up the print preview, reselecting this button return you to Model space (drawing area).
 Close;
 Quit;
 Recent Files; show location of drawings opened presently or in previous drawing sessions. Click on location 

to open the drawing again.  Useful when you have 'lost' a drawing.

Options (2nd Word on Menu Bar)
This area is composed of 5 divisions (with the first 2 being the most useful), as follows:

 Application Preferences
 Current Drawing Preferences

This area has 5 Tabs with the titles: Paper; Units; Grid; Dimensions; Splines
 Paper
 Units
 Grid
 Dimensions

 General Scale:  Normally the length factor should be left as 1.  As we draw in real world 
values with 1 unit representing one unit (1:1) and scaling down is carried out at the printing 
stage.  So a line 20 units long will be dimensioned 20 units long.  If set to 0.5 (as a 'size 
scale factor') it will be dimensioned as 10 but if you use the LibreCAD Measuring tool it still 
will be shown as 20 units.  The setting General Scale is about adjusting the size of text, 
numbers, and dimensioning elements to the intended print scale.  Instead of adjusting these 
for the print scale of 1:100 just type in 100.

 Splines
 Widget Options
 Device Options
 Reload Style Sheet 

Edit (3rd Word on Menu Bar)
This area is composed of 7 sections, with many duplicated in other icons and tool bars:

 Selection Pointer. Refer to section Selection Pointer
 Undo: to undo or go back one command at a time 
 Redo: to redo the last command, step forward.
 Cut
 Copy
 Paste
 Delete Selected.  Refer to section Delete / Erase and Edit Commands

View (4th Word on Menu Bar)
This area is composed of 11 sections, with many duplicated in other icons and tool bars:

 Fullscreen
 Status bar
 Grid
 Draft

Draft View:  When pressing this icon, all your hatches become invisible and all images and text only have 
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their bounding boxes shown.  You can use this when you have a lot of hatches in your drawing and want to 
prevent LibreCAD slowing down when rendering your drawing.  (Source LibreCAD Users Manual – LibreCAD Wiki 
downloaded 12/12/2016 page 16)

 Redraw
 Zoom In
 Zoom Out
 Auto Zoom
 Previous View
 Window Zoom
 Zoom Panning

Plugins (5th Word on Menu Bar)
This area is composed of 8 sections, generally specialised functions:

 Align
 Read ascii points
 ESRI Shapefile
 List entities
 Read PIC file
 Plot plugin
 Same properties
 Sample plugin

Tools (6th Word on Menu Bar)
This is the main area for drawing functions.

 Line  ► (the following 14 actions)
 2 points
 Angle; 
 Horizontal; 
 Vertical; 
 Rectangle; 
 Parallel through point
 Parallel;  (Acts like the Offset command in other applications).
 Parallel bicesector.  
 Tangent (P,C); 
 Tangent othogonal;
 Orthogonal;
 Relative angle; 
 Polygon (Cen, Cor); that is Centre to Corner of polygon.
 Polygon (Cor, Cor); that is Corner to Corner of polygon.


 Circle  ► (the following 9 actions)
 Center, Point
 2 Points; 
 2 Points, Radius; 
 3 Points; 
 Center, Radius; 
 Tangential 2 Circles, 1 Point;
 Tangential 2 Points;
 Tangential 2 Circles, Radius;  
 Tangential 3 Circles; 

Widgets (7th Word on Menu Bar)
This area is composed of 2 main areas:

 Dock Area ► (the following 5 areas)
 Left
 Right (highlighted) – the areas below in Dock Widgets are located on the right of drawing area.
 Top
 Bottom
 Floating
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 Dock Widgets ► (the following 13 areas)  - tick to your usage and preference.
 Block List (ticked)
 Command Line (ticked)
 Layer List (ticked)
 Library Browser (ticked)
 Circle
 Curve
 Dimension
 Ellipse
 Info
 Line
 Modify
 Polyline
 Select

 Tool Bars ► - tick to your usage and preference.
 Categories
 Circle
 Creators (not accessible)
 Curve (ticked)
 Default Custom
 Dimension (ticked)
 Dock Areas (ticked)
 Edit (ticked)
 File (ticked)
 Info
 Line
 Modify
 Order
 Pen (ticked)
 Polyline
 Snap Selections (ticked)
 Tools Options (ticked)  Identified by the letter Ex at the beginning of the tool Bar; standing for 

Exclusive Snap Mode.  Location: top of Drawing Area (3rd row) alongside 3 By Layer controls.  
 View (ticked)
 Menu Creator (for advanced User)
 Toolbar Creator (for advanced User)

Drawings (8th Word on Menu Bar)
This area is composed of 6+ sections:

 Tab Mode
 Cascade
 Tile
 Tile Vertically
 Tile Horizontally
 Open Drawing Title 1
 Open Drawing Title 2 (etc.)

Help (9th Word on Menu Bar)
This area is composed of 2 sections.  There is no Help File for off-line use at present.

 Online
 About LibreCAD - where version information can be found

TOOL BARS - 1st Row

File Tool bar 
1st on left hand side, under Menu Bar
 
This bar is the basic bar that you may find in many applications, hover your curser over each icon picture and you 
will see that there are 7 tools descriptions being in order left to right:
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 New (to create drawing file);
 New (create from drawing template;
 Open (a saved drawing file);
 Save (a current drawing file);
 Save As; (save a copy of the drawing into another area)
 Print (draw);
 Print preview.

Additional information will be added here for these sections as it become known.  

LibreCAD operates with the file having a .DXF format.

Edit Tool bar 
2nd Tool Bar under Menu Bar, alongside above

This bar is a basic bar that you may find in many applications, hover your curser over each icon picture and you will 
see that there on this bar 6 tools descriptions being in order left to right:

 Selection pointer; Refer to section Select 
 Undo (the last operation, each time button pressed);
 Redo (the last operation) 
 Cut;
 Copy;
 Paste.

View Tool bar 
3rd Tool Bar under Menu Bar, alongside above

This bar is for navigating around drawing area.  Hover your curser over each icon picture and you will see that there
on this bar 9 tools descriptions being in order left to right:

 Grid (toggle, show or removed);
 Draft Mode (toggle, On or Off); Generally have off or text will disappear except for showing bounding boxes.

Draft View:  When pressing this icon, all your hatches become invisible and all images and text only have their 
bounding boxes shown.  You can use this when you have a lot of hatches in your drawing and want to prevent 
LibreCAD slowing down when rendering your drawing.  (Source LibreCAD Users Manual – LibreCAD Wiki downloaded 12/12/2016 
page 16)

 Redraw (the work)
 Zoom In;
 Zoom Out;
 Auto Zoom; to fit your drawing on to your screen
 Previous View; to come back to your previous view.
 Zoom (to Window); to zoom into a window you have selected
 Zoom Panning. To move your view point in any direction. 

 Refer to important labour saving zoom and pan comments in section Mouse Settings.
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TOOL BARS - 2nd Row
Pen Selection Tool bar 
1st Tool Bar on 2nd row under Menu Bar 

This shows and permits changing Line colour, Line width and Linetype
Refer to the subsections on Lines,  Line Colours, Line Width, Linetype, Blocks and Layers

Exclusive Snap Mode Tool bar  
2nd Tool Bar on 2nd row under Menu Bar

This tool bar is clearly identified by the large Ex at the left hand of the toolbar (when shown horizontal) on the 
screen.    The snap modes are remembered in each state.  The icons from left to right function as described below 

This bar allows to bind to (or be free from) the first part of a entity to another part of a entity, point or grid.  
 Ex; when the Ex is ON  (depressed) only one snap mode if allowed. When OFF (not depressed) multiple snap 

modes are allowed.
 Free  (No Snap); every point can be selected.
 Snap grid; use when grid visible and you want to snap to intersection of it.
 Snap Endpoints;
 Snap on Entity; to a point on an entity;
 Snap Centre; circle or ellipse;
 Snap Middle of an entity; or 1/3 (trisection) points;
 Snap at a Distance;
 Snap Intersection; 
 Restrict horizontally; only horizontal movement allowed
 Restrict vertically; only vertical movement allowed
 Set relative zero (sets the relative zero position)
 Lock relative zero (Locks the current zero point position)

1.1 EX
When the Ex is ON  (by depressing the Ex) only one snap mode if allowed. When OFF (not depressed) multiple snap 
modes are allowed.  The snap modes are remembered in each case.  Icon: Ex (abbreviation for exclusive snap mode 
tool).

1.2 SNAP FREE
Commands: os, sf
Allows  for the crosshairs to move freely while other snap nodes are enabled.  Icon: broken line cross.

1.4 SNAP GRID
Commands: sg
Snap to a grid Intersection.  Icon: 12 grid points
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1.5 SNAP  ON ENDPOINTS
Commands: se
Snap to the endpoints of a line segment, or the quadrants of a circle or of a point.

1.6 SNAP  ON ENTITY
Commands: np, sn
Snap to the path of an entity.  Icon: line and arc with multiple nodes.

1.7  SNAP CENTER
Commands: sc
Snap to the center of a circle or ellipse.  It will also snap to the foci of an ellipse.  Icon: node at centre of line and centre of 
circle / or point of ellipse foci.

1.8  SNAP MIDDLE
Commands: sm
Snap to the middle of a path.  Enabling this mode displays a “Middle points” input (window to open).  If you change the 
value to 2 then you can snap to the trisection points of a line segment.  Icon: a node at the center of a line or an arc. 

1.9 SNAP DISTANCE
Commands: sd
If you snap to the endpoint of a line segment then activate 'snap distance and input 50, then it will snap to a point 50 units
from the endpoint on the line segment.  However it will also snap to a point that is 50 units from the other endpoint.

1.10 SNAP INTERSECTION
Commands: si
Snap to the intersection of two entities.  This does not currently work for polylines.

1.11RESTRICT NOTHING
Commands: rn
No icon.  Command only.

1.12 RESTRICT ORTHOGONAL
Commands: rr
Vertical and horizontal lines only.  Icon: a orthogonal cross.

1.13 RESTRICT to HORIZONTAL
Commands: rh
Horizontal lines only.  Icon: a node in the centre of a horizontal line.

1.14 RESTRICT to VERTICAL
Commands: rv
Vertical lines only.  Icon: a node in the centre of a vertical line.

1.15 SET RELATIVE ZERO
The location of the relative zero position is located in the Drawing Area and indicated by a red coloured cross inside
a red hexagon.  The relative position will be set automatically when you create a new point.  You can use “Set 
Relative Zero” to set its location without creating a point.  “Lock Relative Zero will prevent it from automatically 
changing.

The relative zero position gives the job of vector addition to the program.  So if we create a point at 10,20 and want 
the next point at vector 30,40 from the last point we can use the @ symbol in the command line and enter @390,40.
The alternative would be doing the math and entering 40,60.

After pressing the icon, you can set the relative position the same way you would create a point.

1.16 LOCK RELATIVE ZERO
Refer to relative zero position in the sub-section above.  The location of the Relative Zero is within the Drawing Area
as a red cross inside a red hexagon.  The relative position will be set automatically when you create a new point.  
You can use “Set Relative Zero” to set its location without creating a point.  “Lock Relative Zero will prevent it from 
automatically changing.

After pressing the icon, you can set the relative position will not change when creating new points.
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1.17  USE OF SNAPS
While drawing a single element one can change the Snap selection between points.  Example: draw a line, say 
vertical, and a point somewhere; you want to draw a new line that will start from the point and end at the centre of the 
vertical line, select 2 Points line and Snap on Endpoints then start your line on the point drawn, now de-select Snap on 
Endpoints and select Snap Middle and end your line in the middle of the vertical one.  NOTE: you could have selected 
both Snaps together and it works but this is just an illustration of possibilities.
Retrieved from “http://wiki.librecad.org/index.php?title=Snapping&oldid=2144 modified 28 January 2017, at 3:42.

1.18  USE OF GRIPS
If you look closely at the endpoints of a line there are two blue dots, they are important because if you click one of the 
two endpoints and keep the left mouse button clicked depressed), the line becomes elastic and you can drag it wherever 
you want, even to an endpoint snap!  Notice that if you select more than entity at once you can move one point, but two 
entities will be modified. 

TOOL BAR CREATION 

Not recommended for inexperienced.  
You can place a selection of all the tools you use on a toolbar.  Use Widgets/Toolbar creator feature. It works, sort of, 
unless you later want to modify that toolbar. The program may crash when trying to access the Widget/Toolbar creator.

If you are willing to start from all default settings: Application Preferences > Defaults > Clear Settings > All
That will also delete all custom widgets.  Otherwise you need to edit the registry.
http://doc.qt.io/qt5/qsettings.html#platformspecificnotes.../LibreCAD/CustomToolbars
Forum Jan 13, 2017

OPTIONAL TOOL BARS

Depending on the kind of work you do, some individual tools and toolbars will be of more use to than others. 
Eventually you may decide to make your own toolbars with the specific tools you require; but first we need to 
understand what tools are in our 'toolbox' that are available for our use.  

Move your curser over the gray shaded area surrounding the Drawing Area; now right mouse click and a window 
will open with 3 sections we will discuss these in turn:

 Toolbars;
 Dockwidgets;
 Statusbar.

Toolbars
Optional item, ticked items show around the drawing area and can be positioned to suit the user.  Sometimes 
placed on the LHS of the Drawing Area.  Each of the Sections is elaborated on immediately following the list of 
Sections.

 Categories; (ticked as most used currently) – refer below
 Circle;
 Creators; (not accessible)
 Curve; (now not ticked) - refer below
 Default Custom;
 Dimensions;
 Dock Areas;
 Edit;
 Ellipse;
 File;
 Info;
 Line;
 Modify;
 Order;
 Pen; (ticked) [by colour, by layer, by block; lineweight; linetype]
 Polyline;
 Select;
 Tool Options;
 View.
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Categories Icon
With an additional level of 'flyouts' this one toolbar incorporates almost all tools that you will generally use, so is 
likely to be the one you want to become most familiar with.
Line (14): 

 2 points
 Angle; 
 Horizontal; 
 Vertical; 
 Rectangle; 
 Parallel through point;
 Parallel;  It acts like the offset command in other applications. 
 Parallel bicesector.   
 Tangent (P,C); 
 Tangent othogonal
 Orthogonal
 Relative angle; 
 Polygon (Cen, Cor); that is Centre to Corner of polygon.
 Polygon (Cor, Cor); that is Corner to Corner of polygon.

Circle:
 Center, Point
 2 Points
 2 Points, Radius
 3 Points
 Centre, Radius
 Tangential, 2 Circles, 1 Point
 Tengential, 2 Points
 Tangential, 2 Circles, Radius
 Tangential, 3 Circles

Curves:
Ellipse:
Polyline:
Select/Deselect:
Dimensions/Leader:
Modify:
Info:
Circle

Creators 
Not accessible.

Curve
At present this tool bar is located on the LHS immediately under the Drawing Area.

 Center Point, Angles
 3 Points
 Arc Tangential
 Spline
 Spline through Points
 Ellipse Arc (Axis)
 Freehand Line

Dockwidgets
Dockwidgets provides information located on the left or right side/s of the drawing area.  At this stage only the top 
four of the items are ticked but obviously Info and others will be important later.

 Block List (ticked)
 Command Line (ticked)
 Layer List (ticked)
 Library Browser (ticked)
 Circle
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 Curve
 DimensionsEllipse
 Info  
 Line
 Modify
 Polyline
 Select


From LibreCAD ver 2.2 a new toolbar style selection became available.  This permits tool icons for all the tools you 
need to be available as a side bar on the left hand side of the Drawing Area.  The LibreCAD Forum post dated 
October 15, 2016 has the following reference information.  

• Go to  https://github.com/LibreCAD/LibreCAD/wiki/Widgets
• Something to note is that custom menus connected with Ctrl+RightClick or Shift+RightClick, will not cancel 

the current operation, which could be useful for snap modes.
• Also make sure to consider 'Keycode mode' in the command line's menu (if you are using 2.2.0 alpha), 

which automatically accepts 2 character commands.

Command Line:  If you right click in the Command Line area a small window opens giving you the option of clearing 
(removing) the information from this secondary screen.

Status bar
This turns on the area at the bottom of the screen and provides information on the current 'status' of the drawing. 
For example information on the grid settings.  You may want to leave this On.  For more information refer to the 
section Application Screen Description.

SETTING UP SYSTEM PREFERENCES

Go to Menu bar (Words at top of screen) > Options > Application Preferences > Default (tab) > Auto Back up 

Untick Auto Back-Up box (Manually press 'Save' button when needed, perhaps every 5 minutes.  Box can be ticked 
for automatic saving later.  The 'Save' button is last icon (with a floppy disc appearance) on the tool bar to the left of 
the drawing area or located at Menu Bar > Options > Save (4th item on flyout). 

Go to Menu bar > Edit > Drawing Preferences > Paper tab

For Paper Format (Pick Paper Size)  In my case A4
Choose Format by bullet point In my case: Landscape [check millimetre size is correct, in this case 297width 
x210mm height]

Go now to the next tab Units  (that is go to Menu bar > Edit > Drawing Preferences > Units tab

For Main Drawing Unit:  In my case: Set to millimetre
Length

Format: In my case choose Decimal
Precision:  In my case choose 0 [ preview below shows e.g. 14 ]
Angle: In my case Decimal Degrees
Precision: In my case 0.00 [ preview below shows e.g. 30.53º ]

Go now to the next tab Grid (that is go to Menu bar > Edit > Drawing Preferences > Grid tab

Untick Show Grid [this can be ticked at any time in the future]

Dimension tab
Consider in the future

Splines
Consider in the future.  Presently showing 8 splines and can set as a variable to 64.

SAVE and Close.

Print Drawing Preferences – refer to Section Printing - Plotting
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STARTING TO DRAWING

 1.1 Sketch
The first part of any design is a freehand sketch with overall dimensions drawn either full size if of convenient size 
or to a suitable scale.  Draw the object on paper. 

 1.2 Set up object outline using Construction Lines  

1. The first lines of any computer generated drawing are the construction lines, setting the lines to the colour 
magenta, cyan or similar so that the colour stands out as obvious and different from the object outline lines. 
The lines width should be '0'.

2. Make sure Snap on grid is enabled; is using grid.
3. Go to the Lines toolbar (on the left of the drawing area, or Menu bar Tools > Line toolbar, select Horizontal 

line and draw a line through 0,0 by clicking anywhere on the y-axis 0.  This can be the top left hand corner 
or the bottom left hand corner of the drawing.  Decide whatever you think is suitable for you, but used this 
consistantly in blocks and locating text for instance.

4. Switch to Vertical line from the previous tool location and add a second line perpendicular to the first, on the 
x-axis 0.  This is the left-most edge of the drawing.  Next we need to set out bottom (or top) and the right-
most extent of the drawing.  If we want to set out the extent of a A4 size piece of paper, in Landscape 
format  the sheet would be 297mm from left to right and 210mm high.  This will set out the limits assuming 
we are going to be drawing 1:1 or full size.  At this stage you may want to draw something within these 
dimensions, say 200mm wide and 100mm high.

5. Switch to the Parallels with distance type of line on the same tool bar as previously, and a 'distance' text-
input box appears immediately at the top of the Drawing Area just to the right of the Line Colour, Line Width 
and Line Linetype boxes.  Enter '200' in this.  Now when you hover the mouse pointer anywhere to the right 
of the vertical line, a very short indicator line will appears at the x-axis 200 mark; this shows you where the 
line will be placed.  Left mouse click to place this line. Right mouse click at this point to exit the command

6. Repeat a similar Parallels process for the top or bottom line 100mm away.  You can continue in the 
Parallels with distance command until you exit the command by right mouse clicking once.  Now you have a 
200x100mm box.

 1.3 Outlines

Once all the construction lines are drawn, add a new layer with a understandable logical name.  This time not a 
'help' layer, and instead of 0-width lines, use 0.25 mm black lines.  You will thicken these lines depending on their 
required prominence later.

Draw the objects outline; ensuring that 'snap on intersection' is turned 'On' so your lines snap to the intersection of 
the construction lines.

SAVING DRAWINGS

Format
 .dxf  Format  Use File > Save-As if you want to save in dxf (CAD standard format).  Ensuring that the 'Files 

of type' in the drop down says .dxf format and not something else.
 .bmp Format Use File > Export and Save-As .bmp format.
 .svg Format is better quality than .bmp format.  There is a workaround at (http://forum.librecad.org/SVG-

Export-tp5708944.html).

COMMAND LINE 

Taken from the Command Line Manual.

 1.1  Use of Angles with Command Line

If you want to create a point 50 units from the relative zero and turned 60 degrees around it:  Use the @ symbol and
input @50<60.

In LibreCAD the rotation angles are calculated anti-clockwise as if from a compass rose with the direction East (or 3
of 3 o'clock) as 0° (degrees); North East as 45°; North as 90°; North West as 135°; West as 180°; South West as 
225°; South as 270°; South East as 315° and back to East as 0° (360°).
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1.2   Command and Shortform List Preface

The following section, along with other uses allows you to see at a glance what commands are available on 
LibreCAD.  Some Commands have names that may differ from what you may expect.  For example Offset 
command is also called Parallel in LibreCAD.

By using the Command line we can place entities specifically and accurately in a location on a drawing. 

Command Line provides among many functions, an alternate method of imputing information for the program to 
use. It may be an advantage to consider this subject here so that you understand some of the functions when 
needed.  Also includes is the use of the Command Line Calculator.

Notice the Command Line at the bottom left hand side of the screen (in older versions) or the the bottom right hand 
side of the screen presently. 

If it is not visible go to the bottom left hand side of the screen with your curser, right mouse click (assuming you 
have a 3 button mouse, - refer to mouse settings section) and a small window opens up reading Tool Bars, 
Dockwidgets and Status Bar.  In the Dockwidgets ► flyout you will see 2nd from the top of the list Command Line, 
ensure this is ticked.  The Command Line will now appear with Library Browser; Block List; Layer List on the right 
hand side of the drawing area.  

You can toggle between the 4 areas by pressing the 'radio buttons' with your curser. The Command line is at the 
top with the Command (input) below.  When the command line (word) is blue coloured it is waiting for command 
input.   Use of this Command Line input is considered in the Command Line section of this Manual.  Sometimes 
LibreCAD waits for special input so get into the habit of checking if the program wants input from you and has 
written here a request for direction.

On the 'right-hand side of the LibreCad drawing window you will notice areas for creating Layers and Blocks.  
'Comma... is an abbreviation (depending on the size of the font) and stands for 'Command Line', Library Browser is 
also here.

Read this Command Line section along with the following subject – Commands and Short forms List.

Information is adapted from 'A Short Manual For Use From The Command Line' last modified on 29 April 2015, at 
8:19.

For a quick reference list of keyboard commands see: Commands List and Functionality section. 

Keyboard commands or abbreviations (also called shortforms of 2 digits) are intended for people that want to draw 
by entering commands through the keyboard.  This can be faster and/or more precise than by drawing using 
exclusively a mouse and toolbars.

LibreCad is designed with mouse-clicking input, and some options can be, at the moment, only selected by clicking,
not by typing on the command line.

1.3  Using the Command Line

You can press the keyboard Space-bar or Ctrl + M to activate the command line.  When the command line is active
the “command:” (left of where the input appears) turns the title words the colour blue.  So now when you pressing a 
keyboard key you are typing or entering commands into the program.

Press the Escape (Esc) key to leave the command line.  (The Escape key on many types of keyboards is the first 
key on the the left hand side of the top row of keys).  Press the Escape key for a second time and you cancel what 
you have written on the command line.

Shortforms:  If you are entering a two letter command you do not have to use the space-bar as LibreCAD is 
programmed to recognise the two letters as a command.  In other words you do not need to press the Enter key for 
the command to be acted on.  So it may be to your advantage to remember the more used two letter codes. 
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It is possible to enter a partial command, like “cir” and press the “Tab” key to have the command completed to form 
the word “circle”.  If you type too short a segment of a command, such as “c” and press the “Tab” key, the command
output will show “ch, circle, cut” because the command segment you typed is not unique.

Many commands 'prompt you' on the command line asking for further input.  They tell you what input they expect – 
a point for example – and list other possibilities in the square brackets.  For example if you type command “polyline”
and draw at least two segments you get prompted “Specify next point or [undo/close]”. This means that the program
is expecting a point (from the command line or by clicking on the drawing area), or you can select the Undo or 
Close option.  You can do that by typing on the command line or by clicking on buttons on the context toolbar called
Tool Options. 

When there is some value already set and valid, for example when you use the command “offset”, the current value 
is in sharp brackets, like so: Specify distance <5> or select entity or [through].  So you see that value for offset is 5 
units and you can either set a new value by typing it into the command line or using the Tool Options toolbar or you 
can start drawing parallel entities.  So information in angled brackets (<current value>) for example a number, that 
is changeable and the default and information in square brackets ( [options] ) showing that other other features are 
available.

Every command below has a long format and a short format.  For example the command for drawing a line has 
three formats:  line, li, l.

To use the two letter format   li   you do not have to activate the command line.  Just type li and LibreCAD display the 
the prompt.  If you wish to continue drawing with just mouse input, you click on drawing to enter the point, or click 
on the tools palette to select a snap mode or whatever.

Look for the command line. Out of the box it is on the bottom of the right side. When you triggered a drawing 
command, e.g. line of two points, you are asked in the command line to specify the points. You can set these
in absolute coordinates (x,y), or relative to the last point, which then is 'relative zero' and represented with that red 
circle. You have to set an @ in front of the coordinates (@x,y). This 'relative zero' position can also be set
to your liking by the 'set relative zero position' command. You might have to set the proper snapping mode for this.
For some drawing operations an additional bar appears where you can enter values. By default it is somewhere at 
the top. Watch out for this.

Relative coordinates such as @10,20 can also be written as 10..20 (allowing for number keypad input).

1.4  Summary

1. Activate the Command line to turn it blue colour.
2. Type command or keystroke shortform providing program direction.  e.g. line (command) or li (shortform).
3. Prompt asks us for example to enter the first point of a line. Example type 0,0
4. Prompt asks us for example to enter the second point of a line. Example type 70,0
5. Type enter to complete command. Entity appears.  Example: A Horizontal line appears 70mm long. 
6. Now produce a vertical line:
7. Type command or keystroke shortform providing program direction.  e.g. line (command) or li (shortform).
8. Prompt asks us for example to enter the first point of a line. Example type 0,0
9. Prompt asks us for example to enter the second point of a line. Example type 0,70
10. Entity appears.  Example: A vertical line appears 70mm long. 
11. The lines are drawn from the Absolute (0,0 origin) if you want to draw from a 'Relative point' Insert @ before

each set of coordinates.  i.e. start 'first point' from say @0,-20 above.

1.5  Precautions When Using the Command Line

 Activate the Command line: By  1. Click inside the command window (box) OR 2. Press the Ctrl + M 
keyboard keys OR 3.  Press the 'space bar' of the keyboard.  The word “Command” (or word you have 
chosen on initial settings) turns blue colour to show it's activated and awaiting your command.

 Check whether you are on the correct layer.  If not choose the right layer on layer window and activate it for 
drawing.

 Make sure your layer is not a construction layer; all construction lines are of infinite (everlasting) length. You
can right click on a layer and then toggle this state.  There is also an icon (#) next to the layer's name.

More advanced information can be found below:
Retrieved from "http://wiki.librecad.org/index.php?title=User_Interface&oldid=2162"
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Category: Usage  This page was last modified on 10 March 2017, at 06:20.

Command List and Functionality

- Commands are listed alphabetically
- Command is typed in lower case, if in bold font my preferred command abbreviation and 2 letters so automatically acted 
on without activating command line.
- First word in command name is the command Group

Action Command Tool (Button) Command Name Comment

Arc a, ar, arc Arc - 3 Points DrawArc3P

Attributes ma, attr Attributes ModifyAttributes

Bevel ch, fillet (bug?) Bevel ModifyBevel Refer: Chamfer, Fillet

Blocks Explode xp Explode BlocksExplode

Chamfer ch, fillet (bug?) Bevel ModifyBevel Refer: Bevel, Fillet

Calculator cal Type in Command Line

Circle – Centre Point ci, circle Circle - Centre Pt. DrawCircle

Circle – 2 Points c2, circle2 Circle - 2 Points DrawCircle2P

Circle – 3 Points c3, circle3 Circle - 3 Points DrawCircle3P

Circle – Tan 3 Points ct3, tan3 Tangential 3 Circles DrawCircleTan3

Command Line Space-bar or Ctrl +M Activates Command Line

Construction Lines (On Help Layer) Or Use Lines

Copy mv Move / Copy ModifyMove

Delete - Selected er Delected Selected ModifyDelete Refer: Erase - Selected

Deselect - All tn Deselect Everything DeselectAll Refer: Select All

Dimension - Aligned da Aligned DimAligned

Dimension - Leader ld Leader DimLeader

Dimension - Horizontal dh Horizontal DimLinearHor

Dimension - Linear dr Linear DimLinear

Dimension - Regen dimreg Regenerate 
dimensions

ToolRegenerate-
Dimensions

Refer: Regenerate - 
Dimensions

Dimensions - Vertical dv Vertical DimLinearVer

Divide di, div, cut Divide ModifyCut

Edit - Undo u, undo, oo Undo EditUndo

Edit - KillAllActions k, kill Kill EditKillAllActions

Edit - Redo r, redo, uu Redo EditRedo

Ellipse ei, ie Inscribed Ellipse DrawEllipseInscribed

Erase - Selected er Delected Selected ModifyDelete Refer: Delete - Selected

Fillet (1) ch, fillet (bug?) Bevel ModifyBevel Refer: Chamfer, Bevel

Fillet (2) fi, fillet Fillet ModifyRound Refer: Chamfer, Bevel, Fillet (1)

Hatch ha, hatch Tools - Hatch DrawHatch

Help Layer (Construction lines) No longer used. Use Lines.

Kill kill Tools - Edit EditKillAllActions

Information - Angle ang, angle Angle Between 2 
lines

InfoAngle

Information - Area ar, area Polygonal Area InfoArea

Information - Distance dpp, dist Distance point to 
point

InfoDist Refer: Line - Distance

Line l, li, , ln, line Line - 2 Points DrawLine

Line - Bisector bi, bisect Biscector DrawLineBisector Bicects angle with line
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Information - Distance dpp, dist Distance point to 
point

InfoDist Refer: Info - Distance

Line - Freehand fhl, free Line - Freehand DrawLineFree

Line - Horizontal hor, horizontal Line - Horizontal DrawLine Horizontal

Line - Parallel o, pa, offset, parallel Line - Parallel  DrawLineParallel Refer: also Offset

Line – Perpend. ortho, perp Line Orthogonal DrawLineOrthogonal (Perpendicular)

Line - Spline spl, spline Spline DrawSpline

Line - Polygon Poly2, polygon2v Polygon (Cor, Cor.) DrawLinePolygonCorCor Corner to corner

Line - Spline via. points stp, spline2 Spline via Points DrawSplinePoints Refer: Spline – via Points

Line - Tangent tanpc, tangentpc Tangent (P,C) DrawLineTangent1

Line - Vertical ver, vertical Vertical Line DrawLineVertical

Line - Offset o, pa, offset, parallel Line - Parallel DrawLineParallel Refer: Line - Parallel

Line – Parallel via point pp, ptp Parallel through Point DrawLineParallelThrough Line parallel through point

Line - Perpendicular ortho, perp Line - Orthogonal DrawLineOrthogonal Refer: Line - Perpendicular

Mirror mi Mirror ModifyMirror

Modify Trim rm Modify ModifyTrim

Modify Trim Extend xt Modify ModifyTrim

Move mv Move / Copy ModifyMove Refer: Copy

Offset o Modify DrawLineParallel Refer Parallel

Parallel par, parallel Modify - Parallel DrawLineParallel Functions also as Offset

Point po, point Points DrawPoint

Polyline pl, polyline Polyline - Polyline DrawPolyline

Properties - Entity mp, prop Properties ModifyEntity

Rectangle rec, rectang, rectangle Line - Rectangle DrawLineRectangle

Redo uu Modify - Redo EditRedo

Redraw (after Zoom) zr, rg, regen, redraw Redraw ZoomRedraw Refer: Zoom

Regenerate - 
Dimensions

dimreg Regenerate 
dimensions

ToolRegenerate-
Dimensions

Refer: Dimensions - Regen

Restrict - Horizontal rh Restrict Horizontal RestrictHorizontal Part of snap group

Restrict - Nothing rn Restrict Nothing RestrictNothing Part of snap group

Restrict - Orthogonal rr Restrict Orthogonal RestrictOrthogonal Part of snap group

Restrict - Vertical rv Restrict Vertical RestrictVertical Part of snap group

Rotate ro Rotate ModifyRotate

Scale sz Scale ModifyScale

Select - All sa Select Everything SelectAll Refer Deselect All

Snap - to Centre sc Snap Centre SnapCenter

Snap - Distance sd Snap Distance SnapDist

Snap - to Endpoint se Snap Endpoint SnapEndpoint

Snap on to Entity np, sn Snap on Entity SnapOnEntity

Snap - Free os, sf Free Snap SnapFree

Snap - to Grid sg Snap on Grid SnapGrid

Snap – to Intersection si Snap Intersection SnapIntersection

Snap - to Middle sm Snap Middle SnapMiddle

Spline spl, spline Spline DrawSpline Refer: Line - Spline

Spline – via Points stp, spline2 Spline via Points DrawSplinePoints Refer: Line - Spline

Stretch ss Stretch ModifyStretch

Text txt, text Tools- Text DrawText
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Text (M) mtxt, mtext Tools - MText DrawMText

Trim - tm, trim Trim Modify Trim

Trim - 2 t2, tm2 Trim Two Modify Trim2

Undo u, undo, oo Undo (oops) EditUndo

Zoom - Auto za Auto Zoom ZoomAuto Or double click mouse wheel.

Zoom - Pan zp Zoom Panning ZoomPan

Zoom - Previous zv Previous View ZoomPrevious

Zoom (Redraw) zr, rg, regen, redraw Redraw ZoomRedraw Refer: Redraw

Zoom Window zw Zoom to Window ZoomWindow

SHORT-CUTS / HOT-KEYS

Ctrl+N Create new file Ctrl+O Open a file

Ctrl+S Save your drawing Ctrl+M or space Sets the focus/mouse curser to the input line of the 
command line

Ctrl+A Select all/everything Ctrl+K Deselect all/everything

Esc Go back to previous action/end 
the drawing process

Double click the  scroll wheel 
of mouse

Auto zoom

CHANGING PROGRAM and DRAWING SETTINGS

Let's take a look at the Program settings first.

APPLICATION SETTINGS

Go to Menu bar > Options > Application Preferences (1st on flyout).
Application Preferences window opens and shows three tabs – Appearance; Paths; and Defaults.  Mouse click on the 
Appearance tab.

 1.1 Appearance tab

Graphic View (LH side)
 (tick) Snap indicator lines

Options are Crosshair (select); Crosshair 2; Isometric; Spiderweb.
 (untick) Hide curser when snapping
 (untick) Anti-aliasing 
 (tick) Scrollbars 

Useful for navigating around the drawing area.
 (tick) Automatically scale grid
 Minimum grid spacing (px) 0-20 pick 10
 Number of preview entities 0-800 pick 100

Language
GUI Language: selected English (Australia)
Command Language: selected English (Australia)

 This may explain the spelling in this document

Graphic Colors (RH Side)

Select color window – functionality

Colour Number:  A reference document containing 500 colours described by colour name, Hexadecimal (a combination of
6 letters and numbers used to define colours in an HTML document). RGB values (used in computer displays and 
described by stating varying percentages of Red, Green, and Blue).   Similar documents can be found on the Internet and
a typical chart by Cloford.com is found at in this computer at LibreCAD > Drawing Standards
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Snap indicator #FFC200 (mustard)
Background #000000 (Black) – White tends to be harder on the eyes.
Grid color #FFFF00 Yellow – for visibility.
Meta grid color #404040  (khaki)
Selected color #A54747 (rose)
Highlighted color #739373 (lichen)
Start handle color Cyan    - (may change)
Handle color Blue     - (may change)
End handle color Blue     - (may change)

 I have called the numbers a similar name above (not exact) I just can't be bothered remembering the number.

 1.2 Path tab  

Now click the Tab Paths.  Notice we can define folder destinations for things like fonts, hatches, parts library items, 
templates etc.  We want to create a folder for our Part Library and also our Templates.

The default directories are:
 Under Linus: /usr/share/librecad
 Under Windows: C:\Program Files\LibreCAD\resources\library  [This is not done by me and is not recommended]
 Keep your Blocks or Parts in a separate folder location to your LibreCAD program file

You may change these location, if needed.
 Translations
 Hatch Patterns
 Fonts
 Part Libraries
 Template

The Small button opens to Open Drawing directory as explained below.

Should you for some reason have to reinstall LibreCAD your parts library will probably be written over and all your work 
will be gone unless you save it some place else.

In Windows your home directory would be the C: drive.  You can try using C:/Documents/Part   Library or something like 
that.  (This is my Preferred Option).

In the Paths tab click on the Path you want to set and the surround turn to the colour blue.  Now click on the small open 
folder icon on the RHS and you can navigate to the folder location in say C: drive.  Use the 'New Folder' tool to make and 
name say a Template or Parts Folder.  navigate to this folder and the path to this particular folder will be shown in the top 
window.  If you now click on the folder icon to the the left of the path the path is given a blue colour shading and you can 
right mouse click and copy the path.  Close this window returning to the Path window and paste the path into the 
appropiate window for Templates or Parts.  OK to save your path settings.

Because of its importance this information is also repeated in the section Blocks or Parts

 1.3 Defaults tab

Defaults for new drawing (LH side)
 Unit set to Millimetre (alternate Options are: none; Inch; Foot; Mile; Millimetre; Centimetre; Meter; Kilometre; 

Micro-inch; Mil.).

Program Defaults
 (ticked) Auto back up - When ticked this will set-up a copy of your drawing, in case of mishap to the original
 (ticked) Auto save time (set to 60 minutes, to empathise the need to remember to Save often.  

As it is optional to have Auto backup selected if tab auto backup is unticked remember to Save regularly; otherwise you 
could lose work. 

  (ticked) Modify layer of selected entities, at layer activation. 
 This has the following explanation as a tool tip:

“When enabled, activating a layer would modify all selected entities to that new layer.  To change layer of multiple 
entities: first select entities; activate a layer in the layer widget.  This makes all entities modified to belong to the selected 
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layer.”  Refer to subsection Modify > Properties and Modify > Attributes and unticked subsection Drawing Entities -  
April 27, 2016 Forum 

Clear Settings (RH side)
 Layout Button
 All button 

Start – up
 (ticked) Display loaded screen.
 (unticked) Start in tab mode.
 (unticked) Start with window maximised.
 (ticked) Enable CAD dockwidgets
 (ticked) Enable CAD toolbars.
 (unticked) Keycode mode.

Now click OK to close the box.

CURRENT DRAWING SETTINGS

 1.1 Paper Size and Format
We will now look at Current Drawing Preferences.  (Options/Current Drawing Preferences). Everything you do here 
affects the drawing you are currently working on ONLY.  

Go to Menu bar > Options > Current Drawing Settings (2nd on flyout) > Paper tab
 Drawing Preferences window opens in drawing Area
 Click on Landscape format ( ▀  - wider than high) generally used or Portrait format ( █  - higher than wide) to 

place bullet point in box.  
 Note: Landscape A4 [length 297x210mm high in Landscape orientation] is standard for much of the world, 

allowing home printing, and the shape of most objects suits Landscape orientation
 If metric A4 is not appropriate choose other format size with radio button.
 Mentally confirm size and orientation of paper as shown by adding dimensions to prove is correct.  OK.

Is the unit precision broken?
 Current Drawing Preferences > Units affects the statusbar and info tools
 Current Drawing Preferences > Dimensions” affects the dimension tools

 1.2 Units
Go to Menu bar > Options > Current Drawing Settings (2nd on flyout) > Units tab
Here you can change units like in previously (Menu bar > Options > Application Preferences > Defaults tab under Units) 
but the choices are only in effect for this drawing.  Here we want to change the Length from 4 decimal places to just 2.   
Do this by clicking precision and selecting 0.00 from the pull down menu.

 1.3 Grid
Go to Menu bar > Options > Current Drawing Settings (2nd on flyout) > Grid tab
Now click on the Grid tab.  We may want to make sure that 'Show grid' is selected and also orthogonal is selected.  Notice
you can select isometric grid too.

Grid Status numbers found at the bottom of the screen and 2/3 of the way from the left of the screen to the right initially 
should be 10 / 100 .  The smaller number tells you the distance between grid dots, the larger between grid lines.  If we 
choose 1mm as a basic unit (refer to dimensions), then the basic grid has 10mm distance, the grid lines 100mm apart.  
Try placing a dimension to confirm size.   Therefore two main grid lines cover a A4 page.  Now, Zoom In and you will see 
the 1 x 1mm grid.   Try placing a dimension to confirm the size. 

 1.4 Dimensions 
Go to Menu bar > Options > Current Drawing Settings (2nd on flyout) > Dimensions tab
Note options but leave as is initially found.

 1.5 Splines 
Go to Menu bar > Options > Current Drawing Settings (2nd on flyout) > Splines tab
Note options for changing the number of splines in a line like an ellipse but leave as is initially found unless you want too 
change at this stage.
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 1.6 Save this Drawing as Your Initial Template 
Save this drawing with its setting changes as a blank drawing.  In this way when we introduce a blank drawing it will load 
these initial settings as well.  Now left mouse click with curser near to the top of the screen on Menu bar File > Save-As 
and type Blank Drawing (ensure ending in .dxf format) and click save.  Save as type box give options of different drawing 
file formats.  Format .dxf stand for Drawing Exchange Format.  Format .dwg is also a popular format that is not available 
at this time with LibreCAD but you can obtain .dxf to .dwg conversion programs on the Internet.

TO MAKE YOUR OWN TOOLBAR 

This not recommended for inexperienced users as it may cause problems when you want to modify the toolbar or least 
this has been the case.  First decide what commands you use most often. These are possible suggestions: 

Line - Horizontal:  (Otho?)
Line Vertical:
Line Extend/Shorten: (Chamfer?)  Trim2
Line Angle:
Move/copy:  mv
Parallel (offset):
Circle, Point: ci
Distance: dpp
Dimension:
Mtext: mt
Properties:  mp
Save:

PRELIMINARY TOOL USE

Cancel any running command:  Press the Esc (Escape) key on the keyboard twice.  
Remove or Show Grid:  Press the Grid icon under the section Help on the Menu Bar. 
Save: The 'Save' button is last icon (with a floppy disc appearance) on the tool bar to the left of the Drawing area.  Or 
locate at Menu Bar > Options > Save (4th item on flyout).  Get into the habit of saving your work often. 

Line - Horizontal: shortform: L enter
Mouse click in Command line typing area (not in Window) and type L and Enter or click space bar.  Use Ex Snap toolbar 
to choose Ortho (for horizontal and vertical lines).
 
Line Vertical: shortform: vert enter

Line Extend/Shorten: 

Line Angle:

Circle – Centre Point: shortform Ci.

Copy:

Distance:
Dimension:
Text:

COORDINATES

The red cross in the lower left Drawing Area marks the origin User Coordinate System – UCS (x=0, y=0, z=0) of the 
system.  In some case the UCS is a unidentified spot 'in space'.  Every point in the Drawing Area is described as so many
units (e.g. millimetres) in the x (horizontal) plane away from the UCS point and so many units above or below the UCS in 
the y  (vertical) plane. All  minus numerals are to the left of the UCS in the x plain and below the UCS symbol in the y 
plain.  This is called a Cartesian coordinate system.  

You type the symbol (if required) to differentiate the system you are using then type number of units in the x plain; type a 
comma (or other option) and with no space type the number of units for the y plane.  e.g. @12,24 or @-12,-24 are very 
different.  If you get a prompt that you have entered a coordinate incorrectly.  Try typing the coordinate again or undo the 
command and try again.
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 1.1 LibreCAD coordinate Panels
Below the Drawing Area on the LHS are the two Coordinate panels:

Left upper coordinate panel shows Absolute Coordinates (x, y, z) of a point.
Left lower coordinate panel shows Absolute Polar Coordinates (distance and angle) of a point.

Right upper coordinate panel shows Relative Absolute Coordinates (x, y, z) from the last previous point. (@)
Right lower coordinate panel shows Relative Polar Coordinates (distance and angle) from the last previous point.

A description of various systems is explained below:

 1.2 Absolute Cartesian Coordinates (  )
When you type a line command and enter from first point 20,3 to second point 25,10 you are using absolute Cartesian 
coordinates and these are measured from 0,0,0.  When typing negative (or minus numerals) these lines may not shown 
on screen as the UCS is in the BLH corner of the Drawing Area.  Use Zoom extents to see all that you have drawn.

Using Absolute coordinates is often not necessary in real life and can be time consuming and a cause of inaccuracy to 
enter.

 1.3 Relative Cartesian Coordinates (@) 

In reality you often do not need to know the position of an object in the universe in order to draw it.  Relative Cartesian 
coordinates only have meaning from the previous point that is specified, not to a 0,0 location.  
Examples:  
@-5,0 is a horizontal line from a picked point left (-, down or minus) 5 units long along the x axis. y axis is unchanged. 
@0,-5 is a vertical line from a picked point down the y axis 5 units long. x axis is unchanged.
@0, 5 is a vertical line from a picked point 5 units long up the y axis.  
@5,0 is a horizontal line from a picked point right (+, up or positive) the x axis 5 units long . y axis is unchanged

The system is often used with 'blocks' where the component will be used in many locations and then is ''fixed' in that 
position with the 'base point' of the block with now a known coordinate location that is different from that of the other 
blocks.  Just as a Block or Part of a house brick and a wall is made of bricks each with its base point at a different 
coordinate.

This system is often used for objects drawn at 90-degree angles (that is formed mostly from vertical and horizontal lines), 
These lines are called orthogonal lines.  

With Relative Coordinates, think about object placement before drawing the first line.  Start by picking a point somewhere 
on the Drawing Area about a 1/3 of the width, from the left, and about 1/3rd of the height of the of the Drawing Area 
drawing your object to the upper-right of this point.  As the size of the object is finalised you can use zoom extents to 
centre the object on the Drawing Area. 

 A simple way of drawing is to set up a vertical line and cross it with a horizontal line and use offset (also known as
Parallel) all other lines from these two initial lines.  This way you may only need to input the offset distances for 
much of the drawing. 

 Direct distance entry:  As you specify the start point point of a line and at the 'Specify next point or [Undo] 
prompt , move the mouse in the direction in the direction you want the line to go (horizontally or vertically) and 
type the lines length.

 1.4 Absolute Polar Coordinates (  )

Knowing distance and angle of a point from 0,0,0.  Absolute Polar coordinates use the 'less than' symbol (<) on your 
keyboard to indicate 'angle'; with the starting point being from 0,0,0.   

To show absolute polar from 0,0,0 type @ before numerals that indicate distance, then a < symbol (with no space) and 
then required angle numerals in degrees..  e.g. @20<45.  This is 20 units at an angle of 45 degrees counter-clockwise 
from horizontal.  Put another way, that is where a clock hour hand would be at 1:30pm.  

 If you do not know the length overestimate it, you can always trim the excess.

 1.5 Relative Polar Coordinates (@)

Knowing distance and angle of a point from a previous point.  Where you do not know the location of an object you use 
Relative Coordinates which have meaning only relative to the previous point.   The object is floating 'in space' just as a 
plot of land showing a house and land contours may be not connected to a country map system..  
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To show relative points type @ before numerals separated by a comma and with no spaces.  Locations below zero (0) in 
the 2D x,y, planes have a minus (-) sign before the numerals.  e.g. @2,-2.  This is 2 units horizontally to the right (x 
direction) , and 2 units (below 0 in the y direction.  (In 3D x,y,z planes).

 Most commonly used by me.
 If you do not know the length overestimate it, you can always trim the excess.

 1.6 Using Coordinates to Restrict within an Area or Border

Look for the command line. For the standard out of the box set up it is on the bottom of the right side of the Drawing Area.
When you trigger a drawing command, let's say a line of two points, you are asked in the command line to specify the 
points. You can set these in absolute coordinates (x,y), or relative to the last point, which then is 'relative zero' and 
represented with that red circle. You have to type an @ in front of the coordinates (@x,y). This 'relative zero' position can 
also be set to your liking by the 'set relative zero position' command. You might have to set the proper snapping mode for 
this.  For some drawing operations an additional bar appears where you can enter values. By default it is somewhere at 
the top of the Drawing Area to the right of the three Line modification boxes. Look out for this.

DRAWING ENTITIES

It is best to draw in drawing mode and print in Print Preview mode.  You can draw in Print Preview mode but some things 
like snap indicator, curser crosshair and grid are not functional.

Text, arrows and hatch remain the same size no matter the extent you zoom in or out.

 1.1 Copy Entities to another Layer
1. Select an entity from existing layer 
2. Copy it by Ctrl C
3. Create a new named layer and keep it active
4. Paste the entity by Ctrl C to new layer

If this does not work refer to the menu Option bar > Application Preferences > Defaults tab – and ensure you have box 
with tick.  This area :has a tool tip note 'Modify layer of selected entities, at layer activation' and refer the tool tip.   Also 
refer to subsection Modify Properties and Modify Attributes.   April 27, 2016 Forum

LINES

Beware of having a line over another line as it can 'read' as one line.   This can cause problems later when printing and 
hatching when it can 'show'.  It is best to have hatch lines as one continuous polyline that you can remove easily 
especially if on a special layer named 'hatch' or as a Construction line, that is not printed.  You may have to move one 
end of a line away from its location with grips to check if another line is beneath it.

To change the appearance of the end of line from the square end (butt end) style, present default) to round end style, 
refer to LibreCAD Forum December 28, 2016 Line End Style. 

 1.1 Construction Lines
These lines set out the location of all or some lines for your new drawing, without specifying any layers, line-weights, or 
line-types.   Later, at any point make a new layer that is not a construction layer and give a descriptive name (set layer to 
current layer), set lineweight (with a thickness 0.25mm initially, increase thickness later) and required linetype (if not 
'continuous'). This layer will be given a  'Print' layer setting eventually. 

 Make a new layer called 'Construction' or similar and set colour 'By Layer' – yellow or cyan can be seen easily
 Lineweight should be set to set to 0 (0 thickness)
 Linetype to continuous.  
 Set to 'Non-Print'  and you may decide to leave some reference entities as they will not be visible on the print.
 All straight 'Construction' Lines  are of 'infinite' length – i.e. they extend off the screen in both directions.

Example:
1. Make sure Snap on grid is enabled, if used or switch off later.
2. Go to the Menu bar > Tools > Lines > horizontal lines, and draw a line through 0,0 by clicking anywhere on the y 

axis 0. This is the lower edge of the Drawing Area.
3. Switch to vertical lines (Menu bar > Tools > Lines > Vertical Lines) and add a second line, perpendicular to the 

first, on the x-axis 0.  This is the left most edge of the drawing.  Next we need to set out the top and right-
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most extent of the drawing.  The distance we know from a hand drawn sketch as: 200 mm wide, and 100 
mm high.

4. Switch to the Menu bar > Tools > Lines > Parallel - (2nd variety on list), and a 'distance' in the text-input box at the 
top top of the Drawing Area, alongside the three Line set colour, width and linetype windows.  Enter '200' 
in this box.  Now when you hover anywhere just to the right of the vertical line, a very short indicator line 
will appear at the x-axis 200 mark; this will show you where the line will be placed.  Left mouse click to 
place this line.  [You could, but don't exit this command at this point by right mouse clicking].

5. Repeat a similar parallels process for the horizontal top line, '100' from the bottom one that's already done.  Now 
you have a 200 x 100 box.

6. Once all the 'construction lines are drawn, add a new layer with a descriptive name.  This time not a 'construction'
layer.  Do this by refraining from ticking the box in the Layer settings window, and instead of 0-width lines , use 
0.25 mm black lines.   Ensure that the 'Snap on intersection' button is depressed and shows blue colour indicating
it is turned 'ON'.

7. Draw the 'outline' of the box.  This will print as it is not a construction layer. 

You can toggle between 'construction' and normal mode three ways:
 Open the Layer List which is on the RHS of the Drawing Area.  With the Auxiliary window Layer List active; right 

mouse click in the window area. and the  #  icon (perhaps symbolising construction lines for a square) will turn 
green as 'ON' when you choose the last item on the flyout – 'Toggle Construction Layer'.  Repeat and the green 
icon will toggle 'OFF' 

 Right mouse click on a layer in the Layer List window and choose 'Toggle Construction Layer' (last on list)
 Click the 'check-box' in the Layer Settings window.  To access the 'check-box' with the Auxiliary window Layer 

List active; right mouse click in the window area. and select Edit Layer Attributes  (4th item up flyout) and the 
Layer Settings window will open so you click (tick) the square 'check-box'.

To set/unset the construction ( the old 'help') layer feature go to Main Menu > Layer > Edit Menu and in the Layer Settings
window tick or untick the Construction Layer box.

Similar material is also to be found in the section Layers subsection Construction Layers

 1.2 Drawing Orthogonal Lines from Point
Command: Ctrl+tap the required direction number pad keyboard arrow

After drawing a orthogonal line (as say one side of a wall) input into the command line a distance then press Ctrl+number 
pad arrow in the direction you require the line to be parallel.  Additionally, after you have input a distance (100) the 
command line will remember the distance so you can just hold Ctrl (Command for Mac) and continue pressing arrow 
keys.  e.g. Require parallel lines 100mm distance vertically or a desired.  Input 100 into command line then press Ctrl+↑ 
gives point.

Another Method to produce lines using keyboard:

L50 or l50 > left 50 distance [relative]
R50or r50 > right 50 distance [relative]
U50 or u50 > up 50 distance [relative]
D50 or d50 > down 50 distance [relative]
(Dec 07, 2015 Forum)

Another Method to produce lines using movement of mouse:

1. First we will pick first point using mouse.
2. Next we know line length 1000mm.  We move mouse in the direction of line.  
3. Then we will enter line length [1000] & press enter or space, line will generate with 1000 unit length in the 

direction of the previous mouse movement. (Dec 07, 2015 Forum)

 1.3 Drawing with Offset  a line or other entity
If you have lines that run at about a 45 degree angle to the orientation of the grid.  Then other lines at a 90 degree angle 
to them. How do I get them to be 90 degrees with no grid to work from?

Use Line > Orthogonal or Line > Angle or Modify > Rotate

 1.4 Drawing with Offset  a line or other entity
Command:
Offset, o 

Specify distance <1> or select entity or [Through]
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You type offset or O at the commandline.  LibreCAD prompts you with a “specify distance ,1. Or select entity or 
[Through]”.  You can enter a number from the command line or using Tools > option toolbar,you can select Through 
option.  The default option is to click near an entity, indicating which side you wish to place the offset on.  Offset works on 
lines, polylines (but only on one segment), circles, arcs, polygons (but on only one segment).  Offset doesn't work on 
ellipses, bezier curves (at least not the way you would expect). 

 1.5 Drawing Parallel lines
Commands: parallel, par.

Specify distance <1> or select entity or [Through]
You type parallel or par on the commandline.

This seems to have the same functionality as Offset command.

A tool opens at the top of the Drawing Area.  There are two adjustments that can be made Spacing and Copies.  
1. Spacing: Check In Menu bar .> Options > Drawing Preferences > Grid tab with the ticked Grid Settings x spacing 

1 and y spacing 1.  Then I set 'Spacing to 1 (1 = 1mm) this way if I want 100m offset I will type in 100.
2. Copies Default is 1 and permits to 99 copies.  If you set to 0; this permits you to offset the polyline once as 

needed indefinitely, until command cancelled.

Spacing with a bit of experience could allow you to make non-standard thicker lines or to experiment with 'white space'.
Caution:  Ensure 'centreline' (the middle of line) is on any 'grid' not the 'edge' of the line.  Use grips to reposition, if found.
If experiment is successful place 'white space' results on Template.

 1.6 Line Width (Lineweight)
Line widths provided are 0.13; 0.18; 0.25; 0.35; 0.50; 0.70; 1.00; 1.40, 2.00.
Change Line width through the Menu bar > Tools > Modify > Properties dialog.

To see width of lines you might need to zoom in to see the width.  The line width is not shown when Draft Mode is 
enabled.  If not seen, check to see that your units are set to millimetres (mm) in Drawing Preferences. If they are set to 
your required units, draw a line 10-15mm long and zoom in.  It should show line width and not remain a thin line.   Refer 
to Export Drawings

In a query on August 13, 2014 a question was asked of the LibreCAD Forum with regards to Lineweight being printed 
being the same regardless of scale printout, which he observed, or should it be the line width be scaled as well?  The 
answer given is “This is by design: 1, line width defined at printing, independent from drawing units/scales; 2, drawing 
scales are defined by user, and differ by a scaling from printed physical dimension;”   The answer was not understood by 
the initial writer or elaborated further.

 1.7 Line Width (Lineweight) with Polylines
Shortform: none found use.  Under Drawing Area tool bar 3 or Menu > Tools > Polyline (5 th down) > 
Use the commend either at Under Drawing Area (3rd tool bar or Menu > Tools > Polyline (5th down) >  “Create equidistant 
polylines” (2nd last on list).  A tool opens at the top of the Drawing Area.  There are two adjustments that can be made 
Spacing and Copies.  

3. Spacing: Check In Menu bar .> Options > Drawing Preferences > Grid tab with the ticked Grid Settings x spacing 
1 and y spacing 1.  Then I set 'Spacing to 1 (1 = 1mm) this way if I want 100m offset I will type in 100.

4. Copies Default is 1 and permits to 99 copies.  If you set to 0; this permits you to offset the polyline once as 
needed indefinitely, until command cancelled.

Spacing with a bit of experience could allow you to make non-standard thicker lines or to experiment with 'white space'.
Caution:  Ensure 'centreline' (the middle of line) is on any 'grid' not the 'edge' of the line.  Use grips to reposition, if found.
If experiment is successful place 'white space' results on Template.

1.8  Linetype Scale
'AutoCAD' calls it LTScale.  There is no LibreCad equivalent as you can't scale the line type.  But there is a work around,  
such as on a flight of stairs where you want to show part of the flight in a broken line as the some steps are above the 
drawing cutting plane.  

Just use a different linetype, in Scale 1:100 drawing dash small or dash tiny will do it.  You can change the line type by 
modify properties (and select the line). Or by modify > attributes.  This allows you to select multiple entities (finish 
selection with 'enter').
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1.9  White Space
Understanding  'White space' will minimise blurred lines when you have drawn a line too close to another line.  It allows 
us to select the most suitable lineweight for the line's location.  As we draw at full size 1:1 and then print to a reduced size
for large objects the white space gap between objects also reduces and we can end up with blurred lines on the print.

Consider another situation; a timber door actually has a gap of around 2.5mm between the door and frame so that the 
door does not stick or 'bind' on opening.  The door and frame detail may have different line weights (the frame is visually 
'weightier' than the door), so in a large scale joinery detail we may want to show the 'gap' as white-space.  How do we do 
this?

If you have two parallel 1.2 mm wide lines drawn with their centrelines one millimetre apart then each line overlaps the 
other and it 'reads' as one thick line with no gap or 'white-space' between the two lines.    If we change the line-width of 
the two lines to 0.25mm we see the white-space.  'White-space' assists in reading the drawing.  If the white space is too 
wide we lose connectivity between the two objects; or if it too narrow we lose clarity.  Determining the width of the white 
space is an aesthetic consideration that is subjective. 

The publication 'International Perspectives on Maps and the Internet' * page 39 and Figure 3.5  suggests that 'white-
space' of 0.15 to 0.2mm is needed between map lines.  With “...one pixel wide the 2 lines are not clearly separated when 
rendered with the Adobe Flash Player 9”. (One pixel is 0.2646mm, when taken to 4 decimal places).  The publication 
Figure 3.5 shows various width gaps between black objects; the gaps being 0.5; 1.0; 1.5 and 2 pixels wide.  These gaps 
are then 0.323; 0.2646; 0.369 and 0.5292 mm wide.  At the beginning of this paragraph we are advised that one pixel 
wide appears to be insufficient white-space.  To my eyes the 1.5 pixel or 0.369mm gap provides the best connectivity / 
clarity balance as white space.

With the information presented in the previous paragraph a White-space Guide can be prepared.  First option:

Draw a series of lines say 20mm long of corresponding (thicker) line weights in the lineweight colours you are using 
preferably and spaced with a 0.369mm (1.5 pixel) gap for each pair of lines.  Note: that this not 'centreline' of the line to 
the 'centreline' of the adjoining line as half of each line projects into white space.  Therefore we need to obtain the total 
width of the two lines and divide this total by 2.  
Therefore the centreline to centreline dimension is:  (lineweight line #1 +  lineweight line #2) / 2 + pixel gap. 

For scale drawings that will be printed 1:1 or larger follow  the following:
1:1: (lineweight line #1 +  lineweight line #2) / 2 + 1.5 pixel gap OR actual gap. 
1:2: (lineweight line #1 +  lineweight line #2) + 3 pixel gap OR 2 times actual gap width. 
1:3: (lineweight line #1 +  lineweight line #2) x 2 + 4.5 pixel gap OR 3 times actual gap width. 
1:4: (lineweight line #1 +  lineweight line #2) x 3 + 6 pixel gap OR 4 times actual gap width. (etc. proportionally)

For scale drawings that will be printed at a scale smaller than 1:1 (e.g. 1:100) :  (lineweight line #1 +  lineweight line #2) / 
2 + pixel gap x scale of drawing.  i.e. when the drawing is reduced in scale the white space size will become the 1.5 pixel 
wide gap. 

We can repeat guide with a gap 2, 3, 4 etc. pixel wide if we want for comparison purposes.  Once drawn at 1:1 scale we 
can easily print this guide to suit any scale drawing we are working with and almost instantly see from our black and white
desktop copy (or printed in lineweight colours) if the white-space for the drawing is suitable for the print.

We need only to do this once because we are talking about white space making the drawing readable on the printed 
drawing.  

Other options:  Set up a Apache Open Office spreadsheet until some clever programmer will set up a tool for LibreCAD. 
Use Calculator command and type in formula.
 
'International Perspectives on Maps and the Internet' edited by Michael P. Peterson pub. 2008 by Springer; ISBN 978-3-540-7208-7.

 Problem: Two skins of brickwork 100 mm wide have a 50mm cavity between them.  The two wall outer lines are 
drawn with a lineweight of 0.5mm and the line either side of the 50mm cavity is drawn in 0.35 lineweight.  When 
printed at 1:100 scale the cavity appears 'overweight'.  Solution, use the information above and reduce the cavity 
lineweight to the next thinner line.

1.10  Modifying Properties 
Command: mp
Prompt:

Type in shortform mp or go to Menu > Modify > Properties (5th up on flyout).
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If you recently used Properties.  Then left mouse click on the line you want the Properties of (it changes color and linetype
when picked.  The options you can change are the Layer; Pen: color, width and linetype; Geometry: start point x & y; end 
point x and y.  (Refer to section Modifying Line Attributes)

If it does not change appearance, check in the Menu > Options > Application Preferences > Appearances tab – Graphic 
colors for what is selected) ) and the Line window opens.  
The options you can change are the Layer; Pen: color, width and linetype; Geometry: start point x & y; end point x and y.  
(Refer to Modifying Line Attributes)

To change the Color left mouse click when curser is over the down arrow (▼) and select the color you want.
 x

To change the Width left mouse click when curser is over the down arrow (▼) and select the color you want.
 x

To change the Linetype left mouse click when curser is over the down arrow (▼) and select the color you want.
 x

You can adjust Geometry by typing in the changed value.

 An alternative to this area via the tool Menu bar is to select Menu bar >Tools > Modify (6th up on the flyout) > 
Properties (5th up on the flyout) and the Line window opens after you click on a line (changes color and linetype) 
and the line window opens.  The options you can change are the Layer; Pen: color, width and linetype; Geometry:
start point x & y; end point x and y.  

 Note that lineweight is visible on screen if you zoom in close.
 If line does not change appearance, check in the Menu > Options > Application Preferences > Appearances tab –

Graphic colors for what is selected and that the Line window opens. 

Layer Types – Benefits and Disadvantages

 1.1 By Layer (Default)

 1.2 By Block

 1.3 Custom Colours

 1.4 Standard Colours (Recommended)

SELECTING COLOURS FOR COLOUR PRINTING

COLOUR (LINEWEIGHT) and LINETYPES CHART

It is recommended that you choose Standard Colours (refer to previous section), International  Standards Organisation  
(ISO; the font is shown in bold italic in the Chart) Linesweights and indicate the various scale drawings Linetypes are 
visually suitable; unless there is a good reason to do otherwise.

Lineweight Comment Lineweight Comment Linetype Comment Linetype Comment

By Layer 0.50 mm By Layer Dash Dot tiny

By Default 0.53 mm By Block Dash Dot small

0.00 mm 0.60 mm No Pen ??? Dash Dot large

0.05 mm 0.70 mm Continuous Divide small

0.09 mm 0.80 mm Dot Divide large

0.13 mm 0.90 mm Dot Tiny Centre

0.15 mm 1.00 mm Dot Small Centre tiny

0.18 mm 1.06 mm Dot Large Centre small

0.20 mm 1.20 mm Dash Centre large

0.25 mm 1.40 mm Dash Tiny Border

0.30 mm 1.58 mm Dash Small Border tiny

0.35 mm 2.00 mm Dash Large Border small
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0.40 mm Dash Dot Border large

 1.5 Colours Selected to Identify Lineweight

Lineweight (Thickness), 
Colour & No.

Comment Lineweight (Thickness), 
Colour & No.

Comment 

Construction 0.25 Yellow (2) Default? - Non Print 1.4  mm Maroon

0.13 mm Not used 2.0 mm Gray

0.25 mm Red (1) Default 0.2 mm Orange (1) Text - Dimensions

0.35 mm Green (3) 0.25 mm Red (1) Text

0.5 mm Cyan (4) 0.35 mm Green (3) Text

0.7 Blue (5) 0.5 mm Cyan (4) Text

1.0 mm Orange 0.7 mm Blue (5) Text

1.6  Modifying Line Attributes

The usage of Attributes compared with Properties: in the 'modify' menu we find action verbs like Divide, Stretch, Explode 
etc., reading Attributes close to Properties may think it the name of a similar function (inactive for some reason).  Using 
Attribute to' should avoid thinking they are the same.

If you want to change an object or a few objects Attributes you can select by picking the object/s with the curser or 
window around the items (from Btm left corner to top R corner, the window will change color to the particular color 
selected in the Menu > Options > Application Preferences > Appearances tab – Graphic colours), right mouse click and 
the tool tip gives you the option of Attributes or Properties; pick on Attributes by picking the tool tip and the Attributes 
Window opens.   Against the following  words Layer; Pen: Color, Width, Linetype you have the option of leaving 
Unchanged or Change.  
 
MENU BAR > FILE or OPTIONS, or EDIT, or VIEW

These first Menu bar sections are basically self explanatory so are not elaborated on at this time.  The other Menu bar 
sections are now discussed in greater detail in the order presented on screen. 

For command line shortforms (abbreviations), instead of using the tool bar selection,  refer to the section Command Line.

MENU BAR >  PLUGINS >

 1.1  Align
Command: none
Location: Plugins > Align (1st on list)

Aligns entities or text with similar.  The curser changes to a hatched cross and the command line says:
 Select objects; (select one or more [window] then press enter key).
 Select base point (from previously selected objects).
 First target point (snap to proposed grid point etc.)
 Second base point (other 'end' of original location entity)
 Second Target point (moved to selected position)

 1.2  Read ASCII points
Command: none
Location: Plugins > Read ASCII points (2nd on list)

 1.3  ESRI shape file
Command: none
Location: Plugins > ESRI shape file (3rd on list)

 1.4  List entities
Command: none
Location: Plugins > List entities (4th on list)

A List Entities window opens on opening location.  Lists Layer, Colour, Linetype, Thickness; Geometry x and y with length
and angle and Identification number.  This tool has more information than Tools > Modify > Properties.
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 1.5  Read PIC file
Command: none
Location: Plugins > Read PIC File (5th on list)

 1.6  Same Properties (Paintbrush)
'Paintbrush' Command: none
Location: Plugins > Same Properties (2nd last on list)

A valuable tool for changing line qualities such as colour, lineweight and linetype to 'match' nearby entities and useful to 
have as a floating toolbar in an open part of the screen.

1.7  Sample Plugin 
Command: none
Location: Menu bar > Plugins > Sample Plugin (last on list)

A Draw Line window opens on opening location.  The option are Start x; Start y; End x; End y and a button 'Accept or 
Cancel'.  Imports a line into the drawing that you have typed the numerals.  A useful tool for for setting up leaders with a 
45° extension for instance.

MENU BAR > TOOLS >  (Draw sections)

Note: Consider the illustration carefully along with the name of the tool; to understand the function of the tool that is on the
toolbar.

LINE

 1.1 Line Two Points
Commands:  l, li, line

After selecting any desired snapping options on the main toolbar you can respond by clicking with the mouse on the 
Drawing Area to enter line start/ finish points.  Or you can enter points by entering into the Command line as shown with 
the following bullet points:

Prompts:
Specify first point 
Specify next point
Specify next point [undo]

• 10,20 [enter] to place line at coordinates x = 10, y = 20 from the origin point at X = 0, y = 0 then
• @30,40 [enter] – to place line at coordinates that are at distance x = 30, y = 40 from the last drawn point; so x = 

10 +30 = 40 and y = 20 + 40 = 60
• 50<45 [enter] to place line at the distance from origin, at 45 degree.  The positive x axis is at 0 degrees , The 

positive y axis is at 90 degrees. So degrees are measured at counter clockwise from horizontal.  Another way to 
express it is with the hour hand of a clock:  3 o'clock = 0 degrees; 12 o'clock = 90 degrees; 9 o'clock = 180 
degrees and 6 o'clock = 270 degrees.

• @60<15 [enter] to place line at the 60 at 15 angle degree from the last drawn line.

OR

Using the mouse
 Go to Draw > Line >2 points
 Click where you want the 1st point to be.
 (as the 'draw line' process is not finished you can use the right mouse button to reset the first point).
 Click where you want the 2nd point to be.
 If you want to have more point just keep clicking on the places you want them to be.
 As the process of 'drawing a line (at least two points)' is done after selecting the 2nd point you can press the right 

mouse button to end the process or press the Esc (Escape) key.

OR

Using the keyboard
 Press Ctrl+M or the 'Space bar' (or click with the mouse into the input line of the 'command line'.
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 Type 'li or 'line' to confirm any command, (unless a two letter shortform which is recognised by the program as a 
commend) you need to now press the enter/return key

 to create the 1st point just type the coordinates of the 1st point '50,50'
 To create the 2nd point type '50,60'
 Now you can proceed in different ways as described in section above Using the mouse.

As you may have noticed every time you create a new point, the 'relative zero point' (cross in circle) is moved to the 
position of this point (if the option “Lock relative zero position” is disabled).  You can use the relative zero point as the 
start point for the next point you want to create.  To do that , you have to type “@” before the coordinates of the next 
point.  So “@60,70 would create a point which is placed 60 units in the x-direction and 70 units in the y-direction (from the
position of the relative zero point.  
If you prefer the polar coordinates for drawing, use “LENGTH<ANGLEINDEGREE” to draw a line.  Typing ”30<45” will 
create a 30 units long line with an angle of 45° (from the absolute zero point).  The “@” sign can be used the same way.
If you are using feet and inches as units you can use “line 1'10”<45 @60'4”<50” to draw a line.

After producing a line segment, any following point create a line segment with the point that precedes them.

If there are at least two segments drawn, you can close the line (draw a segment to the point where you started) by 
entering close into the command line.  To finish drawing lines you press [Esc].

All line segments can be created individually.  With polyline all segments are considered a single object that can be 
selected with one click.

• If you select (pick) a line and right mouse click a small windows gives the function that that created (e.g. Parallel);
right mouse click on the function title and you can continue as if you were still in the command.

• Polylines are useful as hatch boundaries.  They can be deleted if necessary as one continuous line with a 
suitable color and/or conveniently placed on another layer, preferably non-printing.

• Lines are more suitable than Polylines when using Offset command.

 1.2  Line Angle
Commands: 
Prompts:

As discussed previously.

 1.3 Line Horizontal
Command: h, hor, horizontal 
Prompt: 

Press keyboard space key or Mouse click in Command line typing area (not in Window) to turn font colour blue ready for 
input and type l (L ) and Enter or click space bar.  Use Ex Snap toolbar to choose Ortho (for horizontal and vertical lines).

 Restricts to horizontal lines only. 

 1.4 Line Vertical
Command: v, ver, vertical 
Prompt: 

Press keyboard space key or Mouse click in Command line typing area (not in Window) to turn font colour blue ready for 
input and type l (L ) and Enter or click space bar.  Use Ex Snap toolbar to choose Ortho (for horizontal and vertical lines).

 Restricts to vertical lines only. 

 1.5 Line Rectangle
Tools > Line (1st Selection) ►Rectangle (5th on Flyout)
Commands: rec, rectang, rectangle
Prompt:
“Specify first corner”
“Specify second corner”

You type rectangle, rec or rectang on the commandline.  LibreCAD prompts you to with “Specify first corner”.

Check appropriate Snap is colour screened (e.g. 'snap on grid for 0,0,0); enter click on screen for one of the corners of 
rectangle; check Snap icon is screened with tool tip 'Restrict (to) Orthographic' (or other appropriate snap), then either by 
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clicking on the drawing area or by typing coordinates follow the LibreCAD prompt for an diagonally opposite corner.  Left 
mouse click once then right click twice to exit the command. Then Ctrl S to save.

• Use as text box.
• Reports of rectangles resisting being Trimmed.  If a problem compose rectangles from Lines instead.

 1.6 Line Parallel through Point
Commands: pp, ptp
Prompts: 

Refer to following.

 1.7 Line Parallel
Commands: o, pa, offset, parallel
Prompts: 
  
Click (or press space bar) on command line (under Command line Window), if not blue, this turns it blue colour. Now type 
keyboard letter O;  press Enter key.  The Command line Window shows Offset imputed.  
A small window opens on 3rd row of Tool Bars at top of Drawing Area (under the Hel  p section of Menu Bar) This reads 
Distance - type in the offset millimetres (or other unit, you want); then with Number - type in a one or more offsets of the 
line you want; allows 1-99 copies. Your Curser shape changes (mine to a Cross) hover curser over original line you want 
offset and a a broken line copy appears on one side of the line or the other as you desire.  
If the offset is a large dimension and you are zoomed in close, you may not be able to see the offset on screen. Click left 
button on the mouse and the offset lines are added to the drawing.  
Continue using the Offset command with different offset distances or number of lines as needed.  The open Offset 
Window in the toolbar area closes when you Cancel from the Offset command by pressing the keyboard Esc key twice.

• Functions like Modify > Offset

 1.8 Line Bisector
Commands: bi, bisect
Prompts: 

 1.9 Line Tangent Point, Centre 
Commands: tanpc, tangentpc
Prompts:

 1.10 Line Tangent Centre, Centre
Commands: 
Prompts:

 1.11 Line Tangent Orthogonal
Commands: 
Prompts:

 1.12 Line Orthogonal
Commands:  ortho, perp
Prompts:

 1.13 Line Relative Angle

Commands: 
Prompts:

 1.14 Line Polygon Centre, Corner
Commands: 
Prompts:

 1.15 Line Polygon Corner, Corner
Commands: poly2, polygon2v 
Prompts:

 1.16 Line Divide (Refer to Modify Divide)

CIRCLES

 1.1 Circle, Point 
Command:  ci, circle,
Prompt 
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“specify center”
“specify radius”.

Type ci or circle at the Command line.  LibreCAD prompts you to “specify center”.  Here you can enter point for centre, 
either by clicking on the screen or by typing coordinates or type centre and enter centre.  LibreCad prompts you “specify 
radius” dimension.  Do so and the circle is drawn.  Right click twice to exit the command.  Ctrl S to save.

• Other variations of this command follow. 

 1.2 Circle, 2 Points  
Commands:  c2, circle2
Prompts:

 1.3 Circle, 2 Points, Radius 
Commands:  a, arc
Prompts:

 1.4 Circle, 3 Points 
Command: c3, circle3
Prompt:

•LibreCAD draws a circle circumscribed to a triangle

 1.5 Circle, Center, Radius 
Commands: 
Prompts:

 1.6 Circle, Tangential, 2 Circles, 1 Point 
Commands: 
Prompts:

 1.7 Circle, Tangential, 2 Points 
Commands: 
Prompts:

 1.8 Circle, Tangential, 2 Circles, 1 Point 
Commands: 
Prompts:

 1.9 Circle, Tangential, 2 Points 
Commands: 
Prompts:

 1.10 Circle, Tangential, 2 Circles, Radius
Commands: 
Prompts:

 With two circles and want to draw another circle with a given radius which is positioned tangent to the existing two
circles.  Select the first circle. That circle changes its color and LibreCad prompts you to select the next circle, line
or arc, but nothing happens.  You need to increase the radius in window before selecting the 2nd.  Notice the 
option becomes available to set radius in the 2nd icon toolbar.  

 1.11 Circle, Tangential, 3 Circles
Commands:  ct3, tan3
Prompts:
 
CURVE

 1.1 Curve, Point, Angles
Commands:  a, arc
Prompts:
“Specify startpoint or [center]”
“Specify radius”
“Specify start angle”
“Specify end angle or (angle/chord length)”

You type arc or a on the commandline.  LibreCAD prompts you to with “Specify center or [startpoint]”.
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You can enter center point for centre, either by clicking location on screen or by typing coordinates or type center and 
enter or type startpoint and enter.  

Centre:
If you select center you are prompted to enter a centre point and then radius.  After entering the radius you are prompted 
for the starting point angle (in degrees) and then the larger end angle (in degrees).  Arcs drawn by center – radius – start 
point – end angle method always go counter-clockwise from the start point. 

Startpoint:
If you enter startpoint you are prompted to enter second and third point.  LibreCAD draws an arc from the first point 
through the second point to the third one.

• An arc with a centre is part of a circle.

 1.2 Curve 3 Points
Commands:  a, ar, arc
Prompts:

 1.3 Curve Arc Tangential
Commands: 
Prompts:

 1.4 Curve Spline
Commands:  spl, spline
Prompts:

 1.5 Curve Spline through points
Commands:  stp, spline2
Prompts:

 1.6 Curve Ellipse Arc (Axis)
Commands: 
Prompts:

 1.7 Curve Freehand Line
Commands: fhl, free
Prompts:

Also refer to Ellipse

ELLIPSE

 1.1 Ellipse (Axis)
Commands: 
Prompts:

 1.2 Ellipse Foci Point
Commands: 
Prompts:

 1.3 Ellipse 4 point
Commands: 
Prompts:

 1.4 Ellipse center and 3 Points
Commands: 
Prompts:

 1.5 Ellipse Inscribed
Commands:  ei, ie
Prompts:

Also refer to Curves
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POLYLINE

 1.1 Polyline Polyline
Commands: pl, polyline
Prompts:
“Specify first point”
“Specify next point”
“Specify next point or [undo]”

You type polyline on the Command line.  LibreCAD prompts you to with “Specify first point”.

You draw polyline exactly as you would draw a line (refer to sub-section above Drawing a Line).  The only difference is 
that all the segments of polylines are a single entity. 
 

• Polylines are useful as hatch boundaries.  They can be deleted if necessary as one continuous line with a 
suitable color and/or conveniently placed on another layer, preferably non-printing.

• Polylines can be offset, but only one segment, so you may find Lines more adaptable.

 1.2 Polyline Add node
Commands: 
Prompts:

 1.3 Polyline Append node
Commands: 
Prompts:

 1.4 Polyline Delete node
Commands: 
Prompts:

 1.5 Polyline Delete between two nodes
Commands: 
Prompts:

 1.6 Polyline Trim segments
Commands: 
Prompts:

 1.7 Polyline Create equidistant polylines
Commands: 
Prompts: “Choose the original polyline”

The “Create equidistant polylines” tool opens at the top of the Drawing Area.  There are two adjustments that can be 
made Spacing and Copies.  

5. Spacing: Check In Menu bar .> Options > Drawing Preferences > Grid tab with the ticked Grid Settings x spacing 
1 and y spacing 1.  Then I set 'Spacing to 1 (1 = 1mm) this way if I want 100m offset I will type in 100.

6. Copies Default is 1 and permits to 99 copies.  If you set to 0; this permits you to offset the polyline once as 
needed indefinitely, until command cancelled.

Spacing with a bit of experience could allow you to make non-standard thicker lines or to experiment with 'white space'.
Caution:  Ensure 'centreline' (the middle of line) is on any 'grid' not the 'edge' of the line.  Use grips to reposition, if found.
If experiment is success place 'white space' results on Template.

 1.8 Polyline Create Polyline from existing segments
Commands: 
Prompts:

SELECT and SELECTION POINTER

 1.1 Selection Pointer 
Go to Menu bar Edit > Selection Pointer (1st Selection) OR Edit Tool bar > Selection Pointer icon.
When you want to Erase entities you can type shortform er (erase) either pick with curser that has turned into hatched 
cross OR press Selection pointer icon so you can window objects.   You can now pick entities or pick a window (pick 
rectangle left to right is blue colour; pick right to left is green colour).  It does not seem to make any difference whether 
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you use the Selection pointer either to window left to right or right to left (it does in some programs) both will delete object 
only contained within the window.

Once you have windowed entities if you right mouse click a small window opens showing recent commands that you can 
choose and apply to the selection. 

Unable to find any additional information on the use of this function at this time.

1.2  Deselect all 
Commands: tn,  Ctrl+K
Prompts:

 1.2 Select All
Commands: sa,  Ctrl+A
Prompts:

 1.3 Select Entity
Commands: 
Prompts:

 1.4 (De-) Select Contour
Commands: 
Prompts:

 1.5 Select Window
Commands: 
Prompts:

 1.6 Deselect Window
Commands: 
Prompts:

 1.7 Select Intersected Entities
Commands: 
Prompts:

 1.8 Deselect Intersected Entities
Commands: 
Prompts:

 1.9 (De-) Selected Layer 
Commands: 
Prompts:

 1.10 Invert Selection
Commands: 
Prompts:

COPY and PASTE

Just like many other programs LibreCAD allows you to copy and paste any element anywhere,only it can be a little  
surprising.
Draw anything, say a circle. Click on it to select it and either Edit, Copy or Ctrl+C, note that the Command line says: 
"specify reference point", select the centre of the circle. At this stage your screen looks as if you have done nothing. Now 
do either Edit, Paste or Ctrl+V and start moving you mouse, you see a new circle moving about, click where you want its
centre to be located.
NOTE: you can only paste in the layer you copied from, but you can paste in another drawing, to do so open the new 
drawing and only then paste.

 1.1 Moving entity from one layer to another

Suppose you have drawn an entity in the wrong layer, you can correct that.  With the icons select Modify and Attributes 
this will prompt the Select icon tools, choose one and select the entity to move, either press Enter or click on the double 
arrow below the Select icon tools and in the little window that opens choose the layer needed in the Layer line (the first on
top).
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DIMENSIONS

Linear dimensions are generally placed outside the object's perimeter or outline.  To connect the dimension line to the 
object the dimension line has two parallel extension lines from the arrow point, slash, circle or similar (usually at each end
of the dimension line) that nearly touch the point where the dimension it taken from.  The reason that the line has often a 
small gap between the object and the extension line is to lesson confusion by providing a 'white space' so that the object 
extent is clearly seen.
Dimension settings are found at Menu bar Options > Current Drawing Preferences > Unit tab and the Dimension tab > 
Dimension line gap.  Other adjustable dimension settings can also be found here.
Linear precision in the Dimension tab controls the number of digits after the decimal point in the dimension.

1.1 Dimensions Generally
• Directions for Horizontal Dimensions; Vertical Dimensions are similar.
• Enable Free Snap along with Snap Endpoints.
• Select Horizontal from the dimension menu.
• Move the crosshairs over either the left top point or bottom left point of your object and left mouse click once.
• Move the crosshairs horizontally to the  to the right edge of the object and mouse click once.
• Without clicking the mouse move the line up or down and you notice the dimension appears.  
• You can now place it where you want to and when you are satisfied left mouse click once to set the location and 

the right mouse click once to come out of horizontal dimensioning.
• Notice the Icon menu on the left side.  (You can select a dimension option from the menu also now.  As long as 

you only right mouse click once when you finish a dimension the Icon menu will remain).
• To change the size of text in a dimension go to Menu bar > Options > Current drawing preferences > Dimensions 

tab and change text height, arrow size etc.  
• If you have a dimension height such as 39.999 you can adjust precision by going to Menu bar > Options > 

Current drawing preferences > Units and set precision there for length and angle.  For example: choose “0” 
instead of “0.000” and by manually typing in 40.

To move position of dimensions

1. Place your curser on the dimension line and left mouse click once.  
2. Note: that the line turns to a red broken (dotted) linetype to show that it is selected.  Also note a blue point by one 

of the dimension arrows.
3. Touch your curser to the blue point and hold down your left mouse button.  Keep the button held down and move 

mouse and you will see the dimension move with the curser.  Move the dimension to where you want it 
and left click to set the new position.  

4. If you are satisfied with the dimension new position then right click twice to come out of the command.  Otherwise
grab the blue point again and move it where you want it.  Then left mouse click once and right click twice.

5. Click on the line once to deselect it; the line changes from red back to white.

 1.2 Dimension Aligned
Commands: da
Prompts:
“Specify first extension line origin”
“Specify second extension line origin”
“Specify dimension line location”

You type da (abbreviation for Dimension Aligned) on the Command line.  LibreCAD prompts you with “Specify first 
extension line origin”.  Here you can enter point for the first extension line origin, either by clicking on screen or by typing 
coordinates; typically you use some snap to place the dimension exactly on the point you wish to dimension.  LibreCAD 
then prompts you for the second extension line origin.  After this you are prompted for dimension line location; that is 
typically the distance the dimension lines is from the dimensioned object. 

• You use Aligned dimension when you need to indicate the length of the line that runs at the angle
• You can also use it for horizontal or vertical lines, but for that you have specialised commands, see below. 
• You are given a chance to select a line and have it dimensioned like you can with AutoCAD.

 
After issuing command da or clicking on icon or menu you can set other options on the Tool > Options toolbar:

• switch on the optional leader (such as diameter sign)
• enter your own text for dimension
• select the optional leader – diameter, plus/minus sign...
• enter upper and lower tolerances
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 1.3 Dimension Linear
Commands: dr
Prompts:
“Specify first extension line origin”
“Specify second extension line origin”
“Specify dimension line location”

You type dr (abbreviation for Dimension lineaR) on the Command line.  LibreCAD prompts you “Specify first extension 
line origin”.  Hear you can enter point for the first extension line origin, either by clicking on the screen or by typing 
coordinates.  Typically you use some snap to place the dimension exactly on the point you wish to dimension.  LibreCAD 
then prompts you for the second extension line origin.    After this you are prompted for dimension line location.

• Linear dimensions run parallel to the line between the two extension line origins. 
• You use linear dimension when you need to indicate the length under specific angle.
• You have to set the the angle from the Tools > Options toolbar.
• Linear dimension can be used for horizontal and vertical lines but for that you have specialised commands, see 

below.
• You are given a chance to select a line and have it dimensioned automatically like you can with AutoCAD.

 After issuing command da or clicking on icon or menu you can set other options on the Tools > Options toolbar:

• Switch on the optional leader (add 45° line – Refer to subsection Sample Plugins )
• enter your own text for dimension
• select the optional leader – diameter, plus/minus sign
• enter upper and lower tolerances
• enter the angle for the dimension.

 1.4 Dimension Horizontal
Commands: dh
Prompts:
“Specify first extension line origin”
“Specify second extension line origin”
“Specify dimension line location”

You type dh (abbreviation for Dimension Horizontal) on the Command line.  LibreCAD prompts you “Specify first 
extension line origin”.  Hear you can enter point for the first extension line origin, either by clicking on the screen or by 
typing coordinates.  Typically you use some snap to place the dimension exactly on the point you wish to dimension.  
LibreCAD then prompts you  for the second extension line origin.  After this you are prompted for dimension line location. 
Horizontal dimension runs parallel to the x axis.

• You use Aligned dimensions when you need to indicate the length under specific angle.  You have to set the 
angle from the Tools > Options toolbar.

• Aligned dimensions can be used for horizontal and vertical lines but for that you have specialised commands, see
below.

• You use linear dimension when you need to indicate the length under specific angle.
• You have to set the the angle from the Tools > Options toolbar.
• You are given a chance to select a line and have it dimensioned automatically like you can with AutoCAD.

 After issuing command dh or clicking on icon or menu you can set other options on the Tools > Options toolbar:

• switch on the optional leader (add 45° line – Refer to subsection Sample Plugins )
• enter your own text for dimension
• select the optional leader – diameter, plus/minus sign
• enter upper and lower tolerances
• enter the angle for the dimension.

 1.5 Dimension Vertical
Commands: dv
Prompts:
“Specify first extension line origin”
“Specify second extension line origin”
“Specify dimension line location”

You type dv (abbreviation for Dimension Vertical) on the Commandline.  LibreCAD prompts you “Specify first extension 
line origin”.  Hear you can enter point for the first extension line origin, either by clicking on the screen or by typing 
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coordinates.  Typically you use some snap to place the dimension exactly on the point you wish to dimension.  LibreCAD 
then prompts you  for the second extension line origin.  After this you are prompted for dimension line location.  Vertical 
dimension runs parallel to the y axis.

• You use Aligned dimensions when you need to indicate the length under specific angle.  You have to set the 
angle from the Tools > Options toolbar.

• Aligned dimensions can be used for horizontal and vertical lines but for that you have specialised commands, see
below.

• You use linear dimension when you need to indicate the length under specific angle.
• You have to set the the angle from the Tools > Options toolbar.
• You are given a chance to select a line and have it dimensioned automatically like you can with AutoCAD.

 After issuing command dv or clicking on icon or menu you can set other options on the Tools > Options toolbar:

• switch on the optional leader (add 45° line – Refer to subsection Sample Plugins )
• enter your own text for dimension
• select the optional leader – diameter, plus/minus sign
• enter upper and lower tolerances
• enter the angle for the dimension.

 1.6 Dimension Radial
To Dimension a Circle Diameter or Radius:

1. Select Dimension and click Radial on the pull-down menu.
2. Touch the edge of the circle with the curser and left mouse click once.
3. Without clicking your mouse, move it away from the circle, note that the dimension appears.  Now move cursor 

around the circle and you will see the dimension move with it.  Pick a spot you want your dimension and 
left mouse click once and then right mouse click once to come out of the command.

4. If you are not satisfied with the position of the dimension; you can move it by clicking on the dimension and it 
turns red to show it is selected.

5. Touch the curser to the blue point on the edge of the circle and hold the left mouse button down.  Note that when 
you move the mouse you can move the dimension.  When you have the dimension where you want it 
release the left mouse button and click the mouse button once.  If you are satisfied with the position right 
mouse click to come out of the command and left mouse click with your cursor on the dimension to 
deselect it and the dimension will change to the normal white colour.

To Change Properties of Dimensions:

1. Select Tools Menu > Modify > Properties
2. Place the crosshairs over the dimension you want to change and left mouse click it.  A box will pop up and it has 

a pull down menu where you can change the Properties.
3. To change a dimension height, click on Menu bar Edit > Drawing Preferences > Dimension tab and change the 

height by typing in a new value. Then you click on on the OK button and the dimension size will change.

 1.7 Dimension Leader (Text)
Menu Tools >Dimensions > Leader (last on flyout)*
Commands: ld
Prompts: 

* Note that a 'floating toolbar' is available when shown by the broken line (---) at the top of the flyout.

1. Start leader at the arrow-head end of the leader by left mouse click once at the desired location. 
2. If the leader is not initially vertical or horizontal the 'standard' is for the arrow head and a portion of the leader to 

be initially at a 45° angle; so position your curser so that a section is at this angle (use grid if 'ON', or turn 
'ON') and left click once.

3. Then, after estimating the length of the horizontal or vertical section then click once again.  Allow for a small gap 
before starting your future text. 

4. To complete the command press the Enter key and the arrow head will appear on the leader at the first pick point.
Right mouse click once to come out of the command.  

5. Refer to the Text and Sample Plugins Sections of this manual.

• If arrow head size is incorrect check Menu bar Options > Current Drawing Preferences > Drawing Preference 
window > Dimension tab – Dimension lines, arrows & ticks.
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MODIFY

If unable to find Modify go to Menu bar > Tools > Lines (1st item) right mouse click pick tool bars and ensure flyout has 
Modify ticked.  Tool bar icons below the Drawing Area change.

To modify your drawing, either click on the drawing and move the points to use or use: Modify >Edit Entity Geometry or 
Modify > Edit entity attributes.  Some Modify options let you select the entities (lines, circles …) you want to modify, to 
leave the selection mode and tell LibreCAD that you selected all you wanted and press the (??) button in the CAD tool 
bar.  It is mentioned this is one of the most overlooked steps.  
(LibreCAD Brief Overview from “http://wiki.librecad.org/index.php?title=LibreCAD_Brief_Overview&oldid=1723” last 
modified 9 May, 2015, at 02:00.

 1.1 Modify Order
Flyout:

 Move to Top – Home
 Move to Bottom – End
 Raise over entity – PgUp
 Lowerover entity – PgDwn

 1.2 * Modify Move / Copy
Commands: mv
Prompts: 

1. Move a line by dragging:  Move the curser over the line you want to move, click on the line once only to select it.
2. To drag the line selected touch the line with the curser and hold the left mouse button down.
3. While holding the left mouse button down, use the mouse to move the line, and a preview of a line moving 

together with the curser is shown.  Release the left mouse button, after the preview is visible.
4. Use the mouse to move the preview to a new location and left click the left mouse button once to accept the new 

location.  You can see that the has been moved.
5. To deselect the line, click on the line with the left mouse button once, use the shortcut Ctrl-K or Selection Pointer 

within tool bar.
This also works with circles, ellipses, and all lines.  The one thing you have to to remember is if you want to move a 
rectangle or square, composed of separate lines, you need to select each side first.  (If you select only one side; only one 
side will be moved).

 1.3 Modify Rotate
Commands: ro
Prompts: 

Reproducing the issue  from July 27, 2016 Forum:
1. insert a block from the library browser
2. Rotate the block (Tools> Modify.>Rotate)
3. After the rotating copy and paste.
Found that the pasted element is rotated again.  Still current?

 1.4 Modify Scale
Commands: sz
Prompts: 

 1.5 Modify Mirror
Commands: mi
Prompts: 

 1.6 Modify Move and Rotate
Moving a line can be accomplished by dragging or by the Move/Copy action.  First we will discuss dragging:
Dragging:

1. Select a line to move.  Simply move the curser over the line you want to move and click on the line once only to 
select it.

2. Now touch the line to with the curser again and hold the left mouse button down.
3. With the button still held down, use the mouse to move the line and a preview of a line moving together with the 

curser is shown.   
4. Release the left mouse button after the preview is visible. 
5. To deselect the line, click on the line with the left mouse button once.  Use the shortcut Ctrl-K or Selection Pointer

within toolbar.
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• This works with circles, ellipses and all lines.  With a rectangle or square you need to select each side first; for if 
you select only one side, only one side will be moved.

 
 1.7 Modify Rotate 2
Commands: 
Prompts:

 1.8 Modify Revert Direction
Commands: 
Prompts:

Shortform Ctrl+R

 1.9 Modify Trim
Command: tm, trim

You type command on the Command line.  

Prompt: “Select first trim entity”.
 “Select second trim entity”

Curser shape changes to a 'hatched cross' and when you select first line to change it turns to a different color.
Command line prompts you with “Select second trim entity”.
The two lines shorten (or extend) to meet at a 90 degree angle.

• When lines are to 'shorten' ensure you pick the part of the lines you want to keep, not the part to be trimmed off.
• Hold down Ctrl key when cutting the first line to cut more than one line.
• Command appears to either 'Lengthen' or 'Shortening' lines as needed.
• Stays in command until Esc key pressed.
• I prefer Trim 2 command to the Trim command.

 1.10 * Modify Trim 2  

Command: Trim Two, Trim2, t2, Tm2
You type command on the commandline.  

Prompt “Select first trim entity”
             “Select second trim entity”

Curser shape changes to a 'hatched cross' and when you select first line to change it turns to a different color (gray on 
mine).
Commandline prompts you with “Select second trim entity”.
The two lines shorten (or extend) to meet at a 90 degree angle.

• When lines are to 'shorten' ensure you pick the part of the lines you want to keep, not the part to be trimmed off.
• Hold down Ctrl key when cutting the first line to cut more than one line.
• Command appears to either 'Lengthen' or 'Shortening' lines as needed.
• Stays in command until Esc key pressed.
• I prefer Trim 2 command to the Trim command.

 1.11 Modify Lengthen – Two Lines 
Command: Trim Two, Trim2, Tm2

You type command on the Command line.  

Prompt “Select first trim entity”.

Curser shape changes and when you select first line to change it turns to a different colour.
Command line prompts you with “Select second trim entity”.
The two lines extend (or shorten) to meet at a 90 degree angle.

• When shortening lines ensure you pick the part of the lines you want to keep, not the part to be trimmed off.
• Hold down Ctrl key when cutting the first line to extend more than one line or perhaps extend the one line further.
• Command appears to either 'Lengthen' or 'Shorten' lines as needed.
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 1.12 Modify Offset 
Commands: o
Prompts: 

Click on command line, under command line Window, (or press space bar) if not blue, this turns it a blue colour. Now type
keyboard letter O;  press Enter key.  The Command line Window shows Offset imputed. 
 
A small window opens on 3rd row of Tool Bars at top of Drawing Area (under the Hel  p section of Menu Bar) This reads: 
Distance  and Number.

1. Distance: Check In Menu bar .> Options > Drawing Preferences > Grid tab with the ticked Grid Settings x spacing
1 and y spacing 1.  Then I set 'Spacing to 1 (1 = 1mm) this way if I want 100m offset I will type in 100.

2. Number Default is 1 and permits to 99 copies.  If you set to 0; this permits you to offset the polyline once as 
needed indefinitely, until command cancelled.

The option Through requires you to type T first;  it then permits you to position with Grid or Snaps a parallel line where 
you desire on the drawing.

Your Curser shape changes (mine to a Cross) hover curser over original line you want offset and a a broken line copy 
appears on one side of the line or the other as you desire.  
If the offset is a large dimension and you are zoomed in close, you may not be able to see the offset on screen. Click left 
button on the mouse and the offset lines are added to the drawing.  
Continue using the Offset command with different offset distances or number of lines as needed.  The open Offset 
Window in the toolbar area closes when you Cancel from the Offset command by pressing the keyboard Esc key twice.

• Functions like Line > Parallel

Spacing with a bit of experience could allow you to make non-standard thicker lines or to experiment with 'white space'.
Caution:  Ensure 'centreline' (the middle of line) is on any 'grid' not the 'edge' of the line.  Use grips to reposition, if found.
If experiment is successful place 'white space' results on Template.

 1.13 Modify Bevel 
Commands: ch, fillet (bug?)
Prompts: 

Bevels and Fillets: selecting one of these two will prompt little windows below the horizontal icon upper line, the tool 
options, they allow to indicate either the bevel dimensions or the fillet diameter. Many other icons will prompt tool options 
that will allow to add properties to the command.

 1.14 Modify Fillet with Trim Option
Commands: fi, fillet
Prompts: Specify first entity 

  Specify second entity

Bevels and Fillets: selecting one of these two will prompt little windows below the horizontal icon upper line, the tool 
options, they allow to indicate either the bevel dimensions or the fillet diameter. Many other icons will prompt tool options 
that will allow to add properties to the command.

At command entry
a Trim tick box option opens on 2nd icon bar (above drawing area):  

• ticked - removes lines projecting beyond fillet; 
• unticked leaves projecting lines alone.  

Note Window labelled Radius 
• type 0 produces standard trimmed corner.  Perhaps as Trim2 command.  
• type 1 or more is radius dimension of fillet.  May need to zoom in to see action.

Follow first prompts then pause and see options shown for location of fillet by moving mouse.  Then specify second entity.

 1.15 Modify Divide
Commands: di, div, cut
Prompts: 

To divide the distance between two points into a number of equal parts:
Draw a line between the two points and select Tools Menu > Divide and select line (it changes colour) pick Midpoint 
Snap.  Middle Points radio button window open on 3rd Tool Bar line (just above Drawing area) change dial to select the 
number of divisions;  now pick Tools Menu > Points (last item on flyout) and select the number of points indicated on the 
initially selected line.  Now switch off Midpoint Snap and turn Entity Snap on and draw lines from the points. 
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 1.16 Modify Stretch /Shorten
Position: 8th down
Commands: ss
Prompts: 
“Specify the 1st corner”
“Specify the 2nd corner”
“Select reference point”
“Select target point”

Follow the prompts ; select the top TRH corner of the square or rectangle, the BRH corner to identify the part you want to 
stretch.  Now using Midpoint snap (if not using grid) pick the line to stretch, click once where final position for point and 
right click twice.

 1.17 * Modify Properties
Commands: mp, props
Prompts: 

The usage of Attributes compared with Properties : in the 'modify' menu we find action verbs like Divide, Stretch, Explode 
etc., reading Attributes close to Properties I thought is was the name of a similar function (inactive for some reason).  
Attribute to' should avoid thinking they are the same.

You can copy then switch the layer with Modify > Properties (or Attributes).
Or enable this function by going to Application Preferences > Defaults > Modify layer of selected entities, on layer 
activation

Another tool with further entity information can be found at Menus bar > Plugins > List Entities.  When this icon is 
accessed it opens a List Entities window.  It shows Layer, Colour, Linetype, Thickness; Geometry x and y with length and 
angle and object Identification number.  This tool has more information than Tools > Modify > Properties.

Modify > Properties is still a useful tool.  Press space bar to activate Command line area, (it turns blue) and type 
shortform MP (abbrev. of Modify Properties). Curser changes shape to a hatched cross.  Pick the line or identity with the 
curser you want information on and a large reddish colour window opens in the centre of the Drawing Area with variable 
information depending on the item picked; some of it can be modified here.  The information could be on Layers, line 
geometry, dimensions, text and label variables. 

Properties Window
• Layer - change option
• Pen colour – change option
• Pen width – change option
• Pen linetype – change option
• Geometry start point (x):
•                  start point (y):
•                  end point (x):
•                  end point (y):

Activate the properties tool by clicking the icon on the toolbar or from Modify  Properties on the main menu (5→ th from btm
of list).
After you have activated the tool, click on the object you wish to modify  a window will appear.—  

Modify > Properties is not the same as Modify > Attributes.  

1. Modify > Properties informs you of the existing layer; Pen colour, width or line type characteristics of the entity.  
Geometry is also considered here.

2. Modify > Attributes informs you of the existing characteristics while giving you the option to move entity and place 
on another layer; Pen colour, width or line type.  In each case it give you the option to read 'unchanged'  or gives 
you the option to change with a radio button.  Geometry of the entity is not considered in the Attributes command.

Refer to Menu bar Options > Application Preferences > Defaults > Modify layer of selected entities, on layer activation

Refer to LINES - Modifying a Line for further details

 1.18 Modify Attributes
Commands: ma, attr
Prompts: 
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Modify > Properties is not the same as Modify > Attributes.  

1. Modify > Properties informs you of the existing layer; Pen colour, width or line type characteristics of the entity.  
Geometry is also considered here.

2. Modify > Attributes informs you of the existing characteristics while giving you the option to change the entity and 
place on another layer; Pen colour, width or line type.  In each case it give you the option to reads 'unchanged'  or
gives you the option to change with a radio button.  Geometry of the entity is not considered in the Attributes 
command. 

Attributes Window
• Layer - change or changed option
• Pen colour – unchanged or change option
• Pen width – unchanged or change option
• Pen line type – unchanged  or change option

Refer to Menu bar Options > Application Preferences > Defaults > Modify layer of selected entities, on layer activation

 1.19 Modify Explode Text into Letters
Not researched

 1.20 Modify Explode
Commands: xp
Prompts: 

• This may be useful where laser cutting equipment follows a red line and requires the text to be “non-editable text” 
that is blue line strokes and also not solid blue lines.

 1.21 Modify Delete Selected
Commands: er, del (?)
Prompts: 

 1.22 Paintbrush
'Paintbrush' Command: none
Location: Menu bar > Plugins > Same Properties (2nd last on list)

A valuable tool for changing line qualities such as colour, lineweight and linetype to 'match' nearby entities and useful to 
have as a floating toolbar in an open part of the screen.
 
DIMENSIONING STYLE

 1.1 Dimension Style Changes
LibreCAD has tools that make drawing dimensions much easier.  To modify the default you dimensions you can change 
the preferences.  Click on the drawing menu Options and select Current Drawing Preferences.  A dialog panel named 
Drawing Preferences will appear, select the Dimensions tab.  Here you can set:
• font style
• text height -  this is the height of the text of the dimension
• extension line extension – this is the distance that extension line goes over the dimension line
• extension line offset – this is the distance between the beginning of the extension line and the object you are 

dimensioning.  This is important for the readability of the outline of the drawn object.
• extension line gap – this is the distance between the text and the dimension line
• arrow (or alternative ending) size 

Dimension Size Changed  to Suit Print Scale

If to print an object 250mm long at 1:1 the pre-set values in Menu bar Options > Current Drawing preferences > 
Dimensions might be satisfactory but if  you want to print a building to a printed scale of 1:100, you will have to change 
these settings so it fits on the paper.  Go to  Menu bar Options > Current Drawing preferences > Dimensions tab and 
change 'General Scale'.

With 'General Scale' you can modify all the values on the tab (except 'fixed length'), so you don't have to change all the 
individual values for a different scale.  Also ensure a paper size is set.

DIMENSION LOCATION
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Scale Distance to first dimension line
from drawn object

Distance between dimension lines
from first dimension line

1:1 (Full) 15 10
1:2 30 20
1:5 75 50
1:10 150 100
1:20 300 200
1:50 750 500
1:100 1500 1000
1:200 3000 2000
1:250 3750 2500
1:500 7500 5000
1:1000 15000 10000

If you do not see text associated with dimensioning:
▫  You might need to raise the value of Current Drawing Preferences > Dimensions > Text Height
▫  You might also need to adjust the value of Current Drawing Preferences > Dimensions > General Scale.

INFO

 1.1 Info Distance Point to Point
Command: dpp, dist

You type command on the commandline.  
Prompt “Select first trim entity”.

Has the ability to quickly measure lengths and dimensions right inside the drawing.  You can do this by clicking the line 
measurement tool in the left button menu OR Menu bar > Tools > Info >  and then just clicking on two points in the 
drawing. The distance between those two points, using your default units set in  Menu bar > Options > Current Drawing 
Preferences > Drawing Preferences > Units tab.  The result is placed on screen in the bottom status display pane.
A similar method applied to all the tools in this section.

 1.2 Info Distance Entity to Point
Commands: 
Prompts:

 1.3 Info Angle between two Lines
Command: ang, angle
You type command on the commandline.  

Prompt “Select first trim entity”.

 1.4 Info Total length of selected entities
Commands: 
Prompts:

 1.5 Info Polygonal Area
Command: ar, area

You type command on the commandline.  
Prompt “Specify first point of polygon” etc.

TEXT

Text Commands: txt, text
Mtext Commands: mtxt, mtext
Prompts: Specify Insertion point

Menu bar Tools > Text (3rd up list)
Menu bar Tools > Mtext (4th up list)

Typing and locating Text:

1. Mtext is recommended.
2. Window opens 
3. Choose Font
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4. Choose text Height.  (The smaller the number, the smaller the font. Try 5mm; Zoom In if you lose it).
5. Spacing suggest leave as Default (ticked).
6. Alignment select (suggest top left)
7. Click in Text box and type a note and click on OK button.
8. Use Grid and Snaps or switch off for 'eyeball' placement.  
9. (Refer Exclusive Snap Mode Toolbar in Tool Bars - 2nd Row for details of position and function)
10. Use mouse to move text note to near leader. 
11. Click left mouse once and right click once to set location of text.

Moving Text:

1. Left mouse click on text to select it. It will turn red colour.
2. Use Grid and Snaps or switch off for 'eyeball' placement.
3. (Refer Exclusive Snap Mode Toolbar in Tool Bars - 2nd Row for details of position and function)
4. There will be a blue point by the text, place your curser on this and hold down the left mouse button.
5. While held down move the the text where you want it and click the left mouse button once.
6. Click right mouse button once.  The text should be where you want it. 

After clicking 'OK in the Text or Mtext window after typing the note, the command line changes to “Specify insertion point”.
There you can input your insertion point as x, y coordinates.  Otherwise add to the drawing area with snaps or eyeball it.

 1.1 Fonts

Font Name Example Comment

Amri-regular

Azomix

Cursive

Cyrllic_ii

Gothgbt

Gothgrt

Gothitt

Greek_01

Greekc

Greekcs

Greekp

Greeks

ISO

ISO3098

ISO3098_i

Italicc

Italiccs

Italict

Kochigothic

Kochmincho

Kest32b

Ic_opengost_ar

Ic_opengost_br

OpenGostTypeA-Regular

OpenGostTypeB-Regular

Romancs Not available here refer printout Prefered

Romand

Romanp

RomanS

Romansi

Romant
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Scriptc

Scripts

Simplex ABCDEFGHIJ  abcdefghijk   12345678910 Prefered

Standard Not available here refer printout Prefered

Syastro

Symap

Symath

Symbol

Symbol_misc1

Symbol_misc2

Symeteo

Symusic

Unicode

Wgy-unicode

 1.2 Text Height

The text height for a drawing is based on the Font Height multiplied by the Scale of the drawing.  For example if it it 
is decided to use 2.5 mm text in a 1:1 (Full Size drawing) what is the comparable height for this text in a 1:100 scale
drawing?  
Answer:  Font height height x scale (2.5 x 100 = 250mm).  The chart give this information visually (based on the old 
Rapidograph pen sizes, or use a different system); insert row for other Scale, or use spare columns for other pen 
sizes following this principle:

Font  Ht. mm 1.8 2 2.5 3.5 5 7 10 15

1:1 (Scale) 1.8 2 2.5 3.5 5 7 10 15

1:2 3.6 4 5 7 10 14 20 30

1:5 9.0 10 12.5 17.5 25 35 50 60

1:10 18 20 25 35 50 70 100 120

1:20 36 40 50 75 100 140 200 240

1:50 90 100 125 175 250 350 500 750

1:100 180 200 250 350 500 700 1000 1500

1:200 360 400 500 700 1000 1400 2000 3000

1:500 900 1000 1250 1750 2500 3500 5000 7500

1:1000 1800 2000 2500 3500 5000 7000 10000 15000

 1.3 Lineweight

On screen lineweight is shown in Model Space.  All lines are shown as one pixel height, that is 0.25 mm (i.e. that is 
the 'default' width).   

 1.4 Mtext

Mtext shortform mtxt, mtext 
Is an abbreviation for Multilinetext, and is used where more than one line of text is needed; so a column of text is produce 
now or could be needed in the future.  That is, if you add to the note in the future so that it increases in length you want it 
to format into columns of text like M text produces.  

It is frustrating to add to a typed note and find it not M text; so it is best to decide at the beginning to use M text for general
notes exclusively.  Refer to the following point for using single line Text.

For extensive notes such as a drawing that includes an 'Outline Specification' you may find it advantageous to set up the 
font and size, set column width etc and start the notes.  Right mouse click and Copy the text you have started and right 
mouse click and Paste a copy into Apache Open Office Writer or other text processing program that is free to obtain to 
use and obtain.  Continue type writing in the text processing program, formating, and finally spell check your notes  as 
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explained under the subsection Spell Checking.   To place the corrected notes back into the Mtext or Text in your 
drawing; Copy and paste, using the Copy and Past commands as before.

Menu bar Tools > Mtext (4th from Btm of flyout) opens Mtext box.
• Font Name is at Top Left of the Box

 Some True Type Fonts are available.  Use Standard for exercises.  'Simplex' is my favourite as Arial is not available; 
'Romans' may suit engineering drawings.  A drawing of available fonts can be made, a typical one is available in my 
C:Documents\LibreCAD\Drawing Folder\Text Fonts.

• Height (use ISO heights?)
• Default (line spacing if box ticked)
• Line Spacing (1 or more heights can be typed in)
• Alignment (select one of the following; Middle Left alignment may suit the end of a Note Leader)

 Top Left; Top Middle; Top Right
 Middle Left; Middle Center; Middle Right
 Bottom Left; Bottom Centre; Bottom Right

• Angle:  Generally left at 0 degrees.
• Insert of the following Symbols
• Choice of: Diameter (¢); Degree (°); Plus / Minus ( ± ); At (@); Hash (#); Dollar ($); Copyright (©); Registered (®); 

Paragraph (§); Pi (n); Pound (₤); Yen (¥ ; Times (x); Division ( / ).    Position the flashing curser where you want the 
symbol in the text and press your choice 'word' , which is actually a button and the symbol will be inserted in the text.

• Text Box type in using the icons as follows:
• Icons:  Clear Text (1st); Load Text From File (2nd); Save Text to File (3rd); Cut (4th); Copy (5th); Paste (last).
• Insert Unicode:  (Additional symbols)
• Page:
• Character:  (Has flyout with illustration in adjoining 'window').  Position the curser where you want the symbol in the 

text and press the 'window illustration', which is actually a button and that symbol will be inserted in the text.

To add text to the drawing visually checked the settings in the Mtext window are what you want.  Mouse click within the 
text box, type the note and press the OK button and the window will close.  Now back in the Drawing Area, use your 
mouse to move the note to the end of any leader, mouse clicking off any Snaps that prevent you from moving the note to 
the location you want.  You should note that the Prompt at the Command line will say “Specify insertion point”.  You 
specify a text insertion point by clicking on screen or by typing coordinates.  At this point the Command line Prompt will 
again say “Specify insertion point” so that you can insert another copy of the text elsewhere.  Press the keboard Esc key 
to cancel the Text command, when text is inserted sufficiently.

To change Mtext Layer, Pen Color and Linetype properties:
With the note on the drawing, type MP (Modify Properties) in the Command line area and a Mtext window opens up 
(similar to the previous one) with the added ability to change layer, pen color and linetype.

To change Mtext column width:
When typing out text, the problem is that you don't see it live on the screen during typing how it will look, only after 
inserting. As a workaround you could draw a text box in your drawing of your say 3000 mm width first, maybe on a 
different layer so that it does not interfere with the text. The size of this text box to suit different scales can be found in the 
chart in the sub-Section Text Location 

Type your MText without any line breaking and insert it into the box. You will then see where it flows over the border. 
Open the text again with Modify - Properties and in the input window insert a line break with 'Enter' after the last letter that
is within the box. Proceed so on, as you now will see where to insert the next line break.

If for some reason this does not work, you could try the following:

The only work around I thought of was to open MText; type the letters of the alphabet in the font and size I want; insert 
into drawing; draw a vertical line from insert point, offset line (in this case) 3000mm showing the letter place where the 
text column needs to end.  Delete the rest of the alphabet and I have a line of text (my own text ruler so to speak) I can 
now insert the text I want under this to the width I want and lastly delete the part alphabet (the ruler) and locate the 
column of text in the drawing.  Bit of juggling the first time but can copy the text around the drawing and place into your  
drawing template for future drawings. 

• Ensure text heights are added in Preferences area.
• Refer to Appendix for additional information on Justification and fonts.

 1.5 Single Line Text
Single line Text.  Particular used where you require accurate positioning such as in drawing sheet title boxes.
It is frustrating to add to a typed note and find it not format into columns; so it is best to decide at the beginning to use 
Multilinetext (Mtext) for general notes where its ability to form multiline text, that will format into columns is needed.
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Use single line Text where for instance you require accurate positioning such as in drawing sheet title boxes and detail 
titles.

Tools > text (3rd from Btm of flyout) opens Text box.

In the text box the Alignment (justification) section gives point tips when you hover the curser over the alignment icon.  
Alignment justification is Top Left; Centre; Right (proceeding in the Y coordinate direction) and Top Left; Middle; Baseline;
Bottom; (going down the text in the Y coordinate direction) 

With bullet positions of Fit; Aligned and Middle.

 1.6 Text Size
You may find the following architectural metric text sizes helpful:

Text Table 
Typical Use    [height in mm.] Style Height Width Layer Colour
Floor finishes, stair riser numbers RomanS 1.8 0.9
Annotations, revision notes, key 2.5 mm Notes, leader notes RomanS 2.5 0.9
Notes, symbol legends RomanS 2.5 0.9
Cover Sheet Index Eqe- 2.5 0.9
Schedule text RomanS 2.5 0.9
Schedule numbers RomanS 2.5 0.9
Room names 1:100 RomanS 3.5 0.9
3.5mm Notes (other than room names) RomanS 2.5 0.9
Annotations, revision notes, key 2.5 mm Notes, leader notes RomanS 2.5 0.9
Room names 1:50 RomanS 2.5 0.9
Dimension text RomanS 1.8 0.9 As Dim.
Area calculations RomanS No std 0.9 No std

 1.7 Text Location

Scale Text Column Location of Key Notes from 

Width (in mm) Border and then Text (mm)

1:1 60 15 + 10

1:2 120 30 + 20

1:5 300 75 + 50

1:10 600 150 + 100

1:20 1200 300 + 200

1:50 3000 750 + 500

1:100 6000 1500 + 1000

 1.8 Modify Text
1. Select Tools menu
2. Select the Modify option
3. select the Properties option in the Modify menu
4. Although no message appears in the Command window, the mouse pointer changes from an arrow to a cross. 
5. When the pointer has changed to a cross, left click on your text.
6. Mtext dialogue will now appear.
7. edit text
8. click on OK to close dialogue.  Changes now appear in your drawing

 1.9 Spell Checking Text
To spell check drawing notes' open the notes of Mtext or single line Text, highlight the notes; right mouse click and copy 
and Paste (right click and Paste) into a word processing program such as Open Office Writer.  This is an Apache Open 
Source program that is free to use and obtain.  Now you can use the Spelling and Grammar tool found at the Menu bar > 
Tools > Spelling and Grammar to spell check the notes.  Unknown words can be added to the custom dictionary.  Copy 
and paste, using the Copy and Past commands as before; to place the corrected notes back into the Mtext or Text in your
drawing.
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HATCH

Commands: ha, hatch
Prompts:

• Ensure Draft mode Icon is not highlighted when trying to insert hatch or print.

Now the next step is create a hatch on the cut area, so we need to switch to HATCHES layer, then we have to select all 
the blue polygon of “section” layer, now click on Create Hatch, give confirm and for example select on the dialog box the 
hatch “ansi31” scale 1 and angle 0. 
 
POINTS

 1.1 Drawing a Point
Command: po, point
Specify location

You type point or po on the commandline.  LibreCAD prompts you you to with “Specify Location”.

After selecting any desired snapping options on the main toolbar you can respond by clicking with the mouse on the 
drawing area to enter points.  Or you can enter points by entering into the command line [same as for Line command]:

• x,y 10,20 [enter] to place point at coordinates x = 10, y = 20 from the origin point at X = 0, y = 0 then
• @x,y @30,40 [enter] – to place point at coordinates that are at distance x = 30, y = 40 from the last drawn 

point; so x = 10 +30 = 40 and y = 20 + 40 = 60
• distance<rotation This creates a point a specified distance from the origin, The @ symbol means that we 

want the relative zero position to be considered the origin; the coordinates are added to the coordinates of the 
relative zero position.  50<45 [enter] to place point at the distance from origin, at 45 degree.  The positive x axis is
at 0 degrees , The positive y axis is at 90 degrees. So degrees are measured at counter clockwise from 
horizontal.  Another way to express it is with the hands of a clock:  3 o'clock = 0 degrees; 12 o'clock = 90 
degrees; 9 o'clock = 180 degrees and 6 o'clock = 270 degrees.

• @distance<rotation This creates a point a specified distance from the relative zero position, and rotated a 
specified amount of degrees around that point.  @60<15 [enter] to place point at the 60 at 15 angle degree from 
the last drawn point.

• A Point should be used at the origin point at 0,0,0 for all blocks, to identify the block or part insert position.

ZOOMING

 1.1 Redrawing the screen
Commands: redraw, regen, rg, zr, 

You type redraw,  regen or rg or zr (abbreviation of the Zoom Regeneration command) on the Command line.  LibreCAD
redraws the screen.  You can use this command, or an appropriate icon from the Menu bar > Edit flyout. 

 1.2 Zooming Using mouse wheel 
When zooming in and out around the drawing you will most likely probably use the mousewheel.  Just point the pointer to 
the desired detail and scroll the mousewheel forward to zoom in.  Scroll the mousewheel backward to zoom out of the 
drawing.

 1.3 Zooming keyboard shortcuts
Commands: ctrl++, Crlt+- 
Prompts:
Just like in the original Photoshop and also in Firefox and Chrome browsers you can use keyboard shortcuts Ctrl++ and 
Ctrl +- to zoom in and out of the drawing.  This is different than using a mousewheel, because the zoom is always centred
in the centre of the screen.

 1.4 Zooming into selected area of the drawing
Commands: zw
Prompts: 
“Specify the first edge”
“Specify the second edge”

You type zw (abbreviation of the Zoom Window command) on the Command line.  LibreCAD prompts you to specify the 
first edge and then the second edge.  Then it displays the selected area on the entire drawing window.  It is often quicker 
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and more comfortable to use mouse with a wheel and zoom in and out by using a scrollwheel.  By pressing the 
scrollwheel (or a middle button on a mouse) you can pan around the drawing.
Alternative:

1. Click the zoom window icon.
2. Move your curser down to the work area.  Notice you have the orange coloured reference lines and the 

curser turns to a magnifying glass.  Move the curser by the area you want to zoom and hold down the left 
mouse button but do not release it.  Instead, move the mouse to create a window around the area you want 
to zoom. When you have done that release the left mouse button and you will zoom right into that area.  The
smaller the zoom window you create, the closer you will zoom into the area.

3. When you have done, click the previous view icon to zoom back out.

 1.5 Zooming to display entire drawing
Commands: za
Prompts: The commend has no further prompt

You type za (abbreviation of the Zoom All command) on the Command line.  LibreCAD sets the zoom factor so that you 
can see your entire drawing – all the entities.

 1.6 Zooming to previous view
Commands: zv
Prompts:  The commend has no further prompt.

You type zv (abbreviation of the Zoom preVious command) on the Command line.  LibreCAD sets the zoom factor so that
you “undo” the last zoom.

 1.7 Zoom Pan
Commands: zp
Prompts:  The commend has no further prompt.

You type zp (abbreviation of Zoom Panning) on the Command line.  

 1.8 Auto zoom
Commands: Double-Click the middle mouse (scroll wheel) button.
Prompts:  The commend has no further prompt.

 1.9 Zooming around the Curser Position by Keyboard
Zooming use Ctrl+/-.  Holding down the Ctrl key allows this.  The view can be grabbed and dragged by mouse.  

PANNING

1.1  Zoom with Panning using mouse wheel
When zooming and panning around, the quickest and most convenient way is to use the wheelmouse.  Just press it
down and you can pan around the drawing in real-time.  This is very effective when combined with wheelmouse 
zoom in and zoom out functionality. By default, wheel scrolling triggers zooming in/out around the mouse pointer; 
holding down the Ctrl/Shift keys on the keyboard while turning the mouse wheel triggers vertical and horizontal 
panning respectively.

1.2  Panning using mouse wheel
When zooming and panning around, the quickest and most convenient way is to use the wheelmouse.  Just press it down
and you can pan around the drawing in real-time.  

1.3  Panning 
Commands: zp, click and drag to pan zoom
Prompts:  The commend has no further prompt

You type zp (abbreviation of the ZoomPan) on the Command line.  LibreCAD prompts you to click and drag to pan.  This 
command has the big disadvantage that after one grab and drag you are out of the commands  So it is much more 
convenient to use mouse with a wheel and pan with the wheel pressed down; you can also zoom in and out by using the 
scroll on the mouse.

1.4  Panning around the Curser Position by Keyboard
Panning use Ctrl/Shift Mouse Wheel, or Ctrl and Mouse dragging. 
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DELETE / ERASE and EDIT COMMANDS

 1.1 Delete / Erase
Commands: er (erase), delete
Prompts:  Select to delete

Probably one of the most important commands, we certainly cannot do without it.

1. Type shortform er (erase) either pick with curser that has turned into hatched cross OR press Selection pointer 
icon so you can window objects.   You can now pick entities or pick a window (pick rectangle left to right is blue 
colour; pick right to left is green colour) with these last two options if you right mouse click a small window opens 
showing recent commands that you can choose.

2. Move your curser over any entity and left mouse click once, the entity turns into a red broken line.  This means 
that it has been selected.   Now press Delete key on your keyboard.  If deleted object by mistake, you can always
bring it back by clicking on the Undo icon (this is below the word Widgets on the Menu bar).

3. If you want to delete everything you drew, then the easy way would be to go to Menu bar Edit > Delete Selected 
(shortform Del).  You can now pick entities or pick a window (pick rectangle left to right is blue colour; pick right to
left is green colour) with these last two options if you right mouse click a small window opens showing recent 
commands that you can choose.

 1.2 Kill
Commands: kill, k
Prompts:  The command has no further prompt

This command when called on the command line 'kills or clears all actions imputed at the command line.  At times you 
have entered a command, zoomed the drawing, used the command line repetitiously besides hitting the ESC key to exit 
out of the loaded commands.  You can run the 'kill command to clear the cache.  It does not seem to do anything but if 
you open up the command line window you will see it clear out all active commands.  Most of the time you would not need
to use this command but there are times when it seems like the app gets confused at what action to take, the kill 
command clears out everything and cleans the slate.

UNDO, REDO and REGENERATION

Shortcuts: You can use Ctrl+z and Ctrl+y to undo and redo changes.  This quicker and more convenient than using the 
next two commands.

 1.1 Undo
Commands: undo, u, oo
Prompts: The command has no further prompt

You type undo, u or oo on the Command line.  LibreCAD reverts the last change you have made to the drawing.  You 
can repeat the undo command, and every time you use it it takes you one step back through the history of your 
drawing/edit.  Unlike other commands, such as AutoCAD, the undo command doesn't revert the zoom and pan 
commands.

 1.2 Redo
Commands: redo, r, uu
Prompts: The command has no further prompt

You type undo on the Commandline.  LibreCAD cancels the last undo you have made.  When you use the undo, it is easy
to undo one more step than you want.  Using redo you can revert undo.  This lets you go back and forth in the edit history.

 1.3 Regeneration
Commands: dimregen
Prompts: 

Regenerates dimensions.

CALCULATOR 

Uses Command Line.  This feature is available for version 2.0.7 and later.  
Constants: pi = 3.14159265359

 1.1 Operators
Addition:  cal 6+5
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Subtraction: cal 6-5
Multiplication:  cal 6*5
Division: cal 6/5
six to the fifth power:  cal6^5

 1.2 Functions
Square root: calsqrt(5);  cal sqrt (3^2 + 4^2)
Average: cal avg(6,5)

 1.3 Trigonometric functions
Note these functions take radians.  
degrees*pi/180=radians

sine: cosine: tangent:

cal sin(6*pi/180 cal cos(6d) cal tan(6deg)

 Full list of functions (http://muparser.beltoforion.de/mup_features.html#idDef2)
 Trigonometric functions (https://en.wikipedia.org/wiki/Trigonometric_functions)

Retrieved from “http://wikiwiki.librecad.org/index.php?title=Calculator&oldid=2080” 
This page was last modified on 3 June 2016, at 23:00.

BLOCKS or Parts Libraries

1.1 Introduction – Read First
The placement of Parts Libraries is an important consideration.  If not placed in a suitable location any crash of LibreCAD 
or a upgrade of the program may result in the overwriting or deletion of all your blocks / components / or part library. 
It is recommended that you read the following documents before setting one up in a location.  The first one also discusses
how to access LibreCAD standard components suitable for various disciplines.

• Retrieved from "http://wiki.librecad.org/index.php?title=Part_Libraries&oldid=1997"
Category: Installation  This page was last modified on 20 August 2015, at 23:19.

• Forum Dec. 24, 2016 - Ideas on library organisation - please comment - HowIdidit_LibreCAD_symbol_library.odt

1.1 Layer 0
Make your 'Blocks' on Layer 0 following the following guidelines:

 I understand that a block must consist of elements which are all on the same layer.  But why?
Blocks are a powerful tool but must be understood.  Block is a generic term inappropriate for learning

 A block can be a definition or an insertion.
 To use "blocks" you can define a block (block definition)
 then you add in the drawing a entity "insert" (block insertion)
 referencing a "block definition".
 A "block definition" is like a group of entities, it can contain all type of entities (lines, arcs, "block inserts", text...) 

and the entities forming a "block definition" can be in any layer and have any color or linetype.  A "block insert" is 
like a point, is an entity with its layer, color and line type but when it is drawn shows the entities that compose the 
"block definition" at the scale that was inserted.

The LibreCAD Forum question dated  7 March 2012 refered to an attached file, it contain a "block definition" called 
"pieza" this definition have 4 lines in layer "lines" and 2 circles in layer "circles", a "block insert" in layer "block1" and 
another in "block2". If you turn off the block "pieza" both inserts are hidden.  If you turn off the layer "block1" the left 
"insert" is hidden. If you turn off the layer "block2" the right "insert" is hidden.  If you turn off the layer "lines" the lines that 
compose the "block definition" and are in the layer "lines" are hidden.  If you turn off the layer "circles"... then...?

A Block or Part or Component is a group of entities.  Blocks can be inserted into the same drawing more than once with 
different attributes, locations, scale and rotation angle.  Such an instance of a block is usually called an “insert”  Inserts 
have attributes just like entities and layers.  An Entity that is part of an insert can have its own attributes or share the 
attribute of the insert.  Once created, inserts are still linked to the block they instantiate.  The power of the inserts is, that 
you can modify the block once and all inserts will be updated accordingly.

• I have some small parts drawn full size (eg small component or large building floor plan) and want to print out a 
copy of them.  How do I scale the drawing up as a larger scale detail?

1. If you mean to print out part of the drawing use Print Preview that can print out larger than 1:1.
2. Or you may try a different "layer" or make a "block' as part of the drawing,  if for instance you 

wanted Kitchen Detail plan or a small scale site location plan.
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A large selection of Blocks / Parts or Components for use or modified can be found at http://cadblocksforfree.com

1.2   Block (Part) Directory in Separate Location
Keep your Blocks (Parts) in a separate folder location to your LibreCAD program file

Should you for some reason have to reinstall LibreCAD your parts library will probably be written over and all your work 
will be gone unless you save it some place else.

In Windows your home directory would be the C: drive.  You can try using C:/Documents/Part   Library or something like 
that.  (Preferred Option).

If that does not work the default location for the library file is C:\Program   Files\LibreCAD\resources\library. But for the 
above reasons this is not an ideal location.

If you want to leave to have library of blocks on the default location create your directory folders for the blocks under 
C:\Program   Files\LibreCAD\resources\LibreCAD\resources\Library\Architectural symbols ...etc.  But for the above 
reasons this is not an ideal location either.

In Windows power-shell there is no difference between keystrokes / and \.   

1.3   What is Changed and Unchanged
Blocks can contain useful text such as reference notes and dimensions.

Advantages Text  / Dim.  Rotated 'Scaled' Lineweight Colour Line-type Attributes

Block Remains (1) Changeable (2) Changeable (3) Changeable (4) Changeable (5) Changeable (6) Changeable (7)

Note 1. Text and dimensions remain the same, blocks drawings having Entities (components) of different scales
Note 2. Rotation is by default anti-clockwise.
Note 3. Block can be scaled down (e.g. Building Location Plan) or up (e.g. Detail) with text staying the same size  

as the rest of the drawing.
Note 4. Increasing the lineweight can give greater definition in a Details, for instance its outline.

1.4  Properties of Block (Part) Entities, and Block (Part) Insertion
The Chart with Explanatory Notes will try to explain the variables:

Properties of Block Entities Results on Insertion 

1 On any Layer (except O) with Colour, 
Lineweight  and Linetype set to By 
Layer

The Block keeps properties of that layer.  If you insert a block into another drawing without
that layer, the drawing creates the the layer.  If you insert the block into another drawing 
with that layer, but the layer has another color and linetype properties, the block takes on 
of the properties of the layer  that are different from those created on it.  If you insert the 
block on a different layer, the block keeps the properties of the layer on which it was 
inserted, because it reports the layer of the insertion point, not the block objects.

2 On any Layer (except O) with Colour, 
Lineweight  and Linetype you Set in a 
particular required way.

The Block keeps the Colour, Linetype, and Lineweight with the properties that you choose.
If you insert the block into another drawing the drawing creates the layers on which the 
original objects were made.

3 On any Layer (except O) with Colour, 
Lineweight  and Linetype set to 
ByBlock

The block takes on the current colour setting.  (If the current colour is set to By Layer, the 
block will take on the current layer's colour.)  If you insert the block into another drawing, 
the drawing creates the layer on which the original objects were made.  Note: If the 
Colour, Lineweight and Linetype are ByBlock when you create objects for a block, the 
objects are always shown with black/white colour, a default lineweight and a continuous 
linetype.

4 On Layer O with Colour,Lineweight  
and Linetype set to ByLayer or 
ByBlock

The block takes on the layer and properties of the current layer it is inserted on.  If you 
insert the block into another drawing no layers are created.

No. Explanatory Note

3 Suitable for many blocks such as doors, window blocks.  Where lineweight and/or linetype changes, depending on location

4 Simplest method is creating blocks on Layer 0. If you want the block to have a specific colour and linetype, create a layer for 
them and switch to that layer before inserting the blocks.  You can also change the layer of a block after its inserted, in the 
same way you can change the layer of any object.
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1.5 Location of Block (Part) Tools
Block List opens in the same location as the Command Line area.  To have this area available go to Menu bar > Widgets 
> Dock Widgets > Block List (ensure this is ticked). 
[I have Block List (1st on flyout); Command Line (2nd); Layer List (3rd); Library Browser (4th) all ticked currently]. 

1.6  Function of Block (Part) Tools
To have this area available go to Menu bar > Widgets > Dock Widgets > Block List (ensure this is ticked).  Now to to the 
window pane on the right hand side of the Drawing Area.  At the base of the window pane are a number of radio buttons 
each one being have the label the ticked Dock Widget.  Click on the one labeled Block List.  
The Block List window now opens with nine icons at the top labeled (from left to right), as follows: 

1.   Open eye Show all Blocks -

2.   Closed eye Hide all Blocks - 

3.   Rectangle Create Block - 

4.   Green Addition symbol Add an empty Block - 

5.   Green Subtract symbol Remove the empty Block - 

6.   'Write' symbol Rename the active Block - 

7.  Rectangle -  corners highlighted Edit the active Block in a separate window - 

8.   Floppy Disc Save the active Block to a File -

9.   Green Rectangle Insert the active Block -

1.7  Creating a Block (Part)
Think about the following sections before making a block:

1. Blocks can be created from scratch or they can be created from existing entities.
2. Draw all blocks (1:1) full scale or full size. Then all components imported into the drawings are scaled the same.
3. By Layer or By Block; Pen colour, lineweight and linetype.  Refresh your thinking by considering subsection: 

Properties of Block Entities, and Block Insertion.
4. Blocks can be kept for use within the drawing (a local Block).
5. Blocks or made and stored in the external block directory an (External Block). Will these external blocks update 

your internal blocks?
6. Make an intelligent insert point like the the junction of the centreline and the wall face of say a toilet plan block 

allowing for accurate positioning of the component. 
7. Put a marker with the component to show where the insertion point is on the block
8. Move the entities to the insert point at 0,0 this way the block is easy to find on the new drawing, at the 0,0 origin.
9. There are advantages by having standard symbols etc. on the Template drawing where they are modified as 

needed and always up to date.
10. Place block on a 'carrier sheet' hundreds of blocks can be on the same 'carrier sheet'
11. There are advantages by having standard architectural, electrical,  plumbing, components etc. on a 1:1 drawing 

divided into sections that making it easy to locate the individual block among similar items like doors with swings 
or various window type and sizes.  This sheet is always up to date.  Copy and insert the block from this 'carrier 
sheet'.  

12. Have descriptive comment on the carrier sheet below the block so it easily identifiable.
13. Make this drawing 'read only' with a large note so you do not accidently move or change a block.  You can then 

remove the 'read only lock' to deliberately make amendments before locking the drawing again.
14. Do not change blocks in a drawing (if an external block) as this can lead to 'circular paths' where you it is difficult 

to update a block in a drawing. Update from the 'carrier sheet'. 
15. Creating and saving blocks is a useful way on inserting frequently used symbols e.g. windows and doors in a 

house plan.
16. Use a systematic block naming convention, as described below.

1.8  Naming a Block (Part)
There are advantages in having a systematic block naming convention.  The following has advantages.

1. Discipline letter of the alphabet followed by a dash.  A- for Architectural; P- for Plumbing ...etc.
2. Descriptive abbreviation followed by a dash. DR- for door; WD- for window...etc.
3. Size or other category followed by a dash.  820x35- for a door size...etc. 
4. View, that is whether E (elevation); P (plan); or S (section)...etc.
5. The blocks will then sort alphabetically into disciplines on the drawing.
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1.9  Creating a Block (Part) From Existing Entities
If you have already drawn the entities that you want to convert into a block use the following steps.

1. Go to base of Window pane (right of the Drawing Area); select radio button name Block List > Create Block (icon)
2. Please note the selection toolbar to the left.  Use one of the tools from the tool bar or simply click on the entities 

that will make up the block.
3. After finishing selection press Enter or click the button of the selection tool bar, with the double arrow (>>) 

pointing to the right.
4. Now the command line asks you to specify the reference point for the block and the curser becomes a dashed 

cross.
• Click the reference point for the block or enter the coordinates on the command line.
• The reference point is the base of the object when it is inserted. 
• Ideally make 0,0,0 the reference base point. If 'lose' inserted block, look in drawing around 0,0,0.
• Provide a unique name for the new block and confirm it clicking in OK.

1.10  From Scratch
A Block or Part can also be created before placing it in the main drawing.

1. From the Block List (refer above) > Add Block (icon).  Alternatively click the green (+) icon, above the Block list.
2. Provide a unique name for the new block.
3. The new, empty block name will appear in the Block list.
4. Select the new, empty name in the Block list.
5. Select Block > Edit Block or click block button (icon) IN above the Block list.
6. The new block will open in a new sub-window within the current drawing.
7. Draw new entities that will compose the new block.
8. Close the window to return to your main drawing.
• The block or Part must be inserted for it to appear in the main drawing.
• The reference point for the newly created block or is the origin of the coordinate system. 
•   Ideally make 0,0,0 the reference base point. If 'lose' inserted block (Part), look in drawing around 0,0,0.

1.11  Reusing Blocks (Parts)
1. Create a block.
2. Select a block in the block list.
3. Press the Save button in the Block list.
4. Choose the location for choosing.
5. Open a new drawing.
6. File > Import > Block
7. Locate the block in the new drawing.

You can use the library browser.  Set the path in Application Preferences, and have blocks in subdirectories of that path. 
If you have the other drawing open, you can use: 

1. Ctrl+c [copy]
2. Select reference point.
3. Switch drawing.
4. Ctrl+V. [paste]
5. Place.

1.12  Blocks (Parts) Explode
Explode shortform xp

Menu bar > Tools > Modify (6th up) > Explode (2nd last on flyout)

1.13  Deleting Blocks (Parts)

• Blocks cannot be deleted from a drawing all at once.  You need to pick them individually or window the items and 
then press delete.

• Go to subsection Block Directory Location and search for file name in Block (Part) directory location and delete 
from there.

• If the original block (Part) is in the drawing unexploded explode and remove remnants.
• Note subsection Creating a Block - Parts and within the drawing or externally on a template or 'carrier sheet'.

Retrieved from “http://wiki.librecad.org/index.php?title=Blocks&oldid=2083”  modified 21June 2016, at 01:36 and additional information added.
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SKETCHING

Use Tools > Curve > Freehand line (last on flyout) with either 'snap to grid' for ortho lines or 'no snap' for freehand tracing 
from an image or 'landscaping free-form' lines.  Quick and simple and with multiple copying.

TRACING

Could trace a sketch in Inkscape, you could just draw it proportionally in LibreCAD not worrying about the size.
Once this is done simply scale it to the desired size as follows:
Place two lines horizontally separated by the desired dimension, then scale down/up your sketch to the desired height.
You can now proceed to make a Block of the sketch if you desire.

DRAWING SYMBOLS

A large selection of blocks that can be used or modified can be found at http://cadblocksforfree.com   under the category 
Drawing Elements .  The following are a typical selection that could be needed:
Detail Reference Symbol
Detail Title 
Drawing Title Box
Grid Bubbles
Height Symbol
North Points
Scale Bars
Draw at 1:1 as part of building plan then whatever scale you print the drawing the scale bar will change length at the 
same proportion.  For example draw a 10 meter long line with 100mm high vertical lines every one metre and add text 
0m, 1m, 2m, 3m, etc.  For details you could have as part of the Detail Title.
Section Indicators
Welding Symbols

LAYERS 

With a  large building floor plan for instance if you want to make a copy of it complete or part of it at another scale larger 
for a detail or smaller say for a site location plan; you can place a copy onto a different "layer" or make a separate "block" 
(refer subsection Blocks - Parts) as part of the same drawing as the floor plan.

 1.1 Construction Layers
A construction layer (formerly known as a Help layer) is designed to hold geometry construction lines:

• A construction layer won't appear on printout;
• All lines of a construction layer are infinite in length.

You can toggle between construction and normal mode three ways:
• With the Auxiliary window Layer List active; right mouse click in the window area. and the ( # ) icon will turn green

as ON when you choose the last item on the flyout – “Toggle Construction Layer”.  Repeat and the green icon will
toggle OFF. 

• Right mouse click on a layer and choose “Toggle Construction Layer”
• Click the 'check-box' in the Layer Settings window.  To access the 'check-box' with the Auxiliary window Layer 

List active; right mouse click in the window area. and select Edit Layer Attributes  (4th item up flyout) and the 
Layer Settings window will open so you click (tick) the square 'check-box'. 

• Make sure your layer is a construction layer or not; as all construction lines are of infinite (everlasting) length.  
You can right click on a layer and then toggle this state with the 'check box'.  There is also an icon (#) next to the 
layer's name.

Additional clarification can be found at section Lines - subsection Construction Lines

 1.2  Layers
A basic concept in computer aided drafting is the use of layers to organise a drawing.  Every entity in a drawing is on 
exactly one layer and a layer can contain lots of entities.  Typically entities with a common 'function' or common attributes 
are put on the same layer. E.g. you might want all 'centre lines' (axis) on a layer name 'axis'.  Layers can have their 
attributes also (colour, lineweight [line width], linetype [line style] etc.)  Each entity can have its own attributes or have its 
attributes defined by the layer it is placed on.  In the later case for example you can change the colour of all the entities on
the “axes” layer by setting the colour (red for example) for that layer.

In traditional manual drafting, a similar approach was used.  Layers were used to show different aspects of a drawing – 
for example this could be a layer set up for showing centrelines on an engineering drawing or to show different building 
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systems, such as wiring and air-conditioning.  The layers were often drawn on separate transparent sheets of paper.  
These sheets were then overlaid one on top of another to produce final drawings.

Another use of layer is with say with a machine or building where each part is drawn on a different layer.  When the layers
are visible you are able to see the connection between these parts and ensure that the proper tolerances are planned. 

Imagine a drawing of a 'set screw' (similar to a 'bolt') in a machine.  The machine screw 'outline' perhaps in black to 
indicate a heavier lineweight on Layer 1 is called Outline.  The axis centreline in 'centreline' linetype in colour red is on 
Layer 2 called Axis.  Lastly the dimensions of the machine screw – length and diameter are on layer 3 - Dimension layer 
in colour blue; the colour indicating that dimensions may be printed or not, if set as a non-print layer.  Dimensions may be 
printed depending on the drawing use; either as 1. a machine component probably printed or 2. as an overview of the 
complete machine when likely not printed.

1.3  Creating a Layer
Layers are usually created to hold objects with common attributes.  Creating a layer is easy.

1. From the RHS of Drawing Area, Auxiliary screen Btm select Layer List tab > Add a Layer ( green + symbol)
2. Specify a Layer Name (refer subsection Layer names)
3. Optionally specify the Colour, Width and Line type

1.4  Layer Names Convention
There are benefits in having a systematic Layer naming convention.  The following has advantages.

1. Discipline letter of the alphabet followed by a dash.  A- for Architectural; P- for Plumbing ...etc.
2. Descriptive abbreviation followed by a dash. Door- ...etc.
3. A-Door
4. The name should sort alphabetically
5. It is recommended that on the template drawing you have a list of parallel lines say 20mm long and 15mm apart 

with each line set to properties of that layer with colour, lineweight and linetype.  Alongside is typed the layer 
name (listed alphabetically) and for clarity lineweight typed.  When the template drawing is inserted all layers will 
be inserted into the new drawing layer list  

1.5  Changing an Objects Layer
Sometimes it is necessary to change an object's layer.  This describes how to move one or more objects between layers.

1. From the menu bar select Tools > Modify > Attributes (4th up from Btm of flyout)
2. Select the objects you want to change the layer of.  See Selections for a detailed description of how to select 

objects.
3. Select the continue action button (LHS double right arrow Specify a Layer Name (refer subsection Layer names)
4. Optionally specify the Colour, Width and Line type
5. Select the continuous action button (double right arrow >> below the Auxiliary screen)
6. In the Attributes dialog, drop down the Layer selection box and choose the desired layer.

Alternatively you can activate the option Application Preferences > Defaults > Modify layer of selected entities, at layer 
activation.

 1.5  Location of Layer Tools
Layer List opens in the same location as the Command Line area.  To have this area available go to Menu bar > Widgets 
> Dock Widgets > Layer List (ensure this is ticked). 
[I have Block or Part List (1st on flyout); Command Line (2nd); Layer List (3rd); Library Browser (4th) all ticked currently]. 

1.2  Description of the Layer Setting Box
Command: Ctrl+l (that is, Layer)
Prompt:
Layer Settings Box contains:

1. Layer Name box - type in the window
2. Construction Layer check (tick) box
3. Default Pen Colour selection dial 
4. Default Pen Width selection dial
5. Default Pen Line type selection dial
6. OK or Cancel button.

1.3  Adjusting Layer Settings Box
This process can be helpful when setting up a Drawing Template.
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1. Click in the layer Name box and delete 'noname' and type in 'reference' 
2. Check (tick) the 'Construction Layer' check box
3. In the Default Pen Colour selection dial, choose red.  All lines and text from this point will be colour red.
4. Default Pen Width selection dial leave as 0.00mm, as is a 'Construction Layer').
5. Default Pen Line type selection dial leave as continuous at present.
6. Press OK button.

Note that on your Layer list you have you have a 'reference' Layer listed now.  If you now save this drawing as a 'blank 
drawing (or drawing template) the 'reference layer will always be loaded with the drawing.  Now we are going to add some
reference text to this layer.

Note:  The following assumes that the 0,0 (UCS origin) is the bottom left hand corner of any object. If you prefer the origin
to be the top left corner, change the location of the text so that the origin is at the top left and the arrows point to the right 
and downwards from this point .

1. Go to Menu bar Tools > Mtext (4th up on list) and the Mtext text box will open OR
2. Go to Menu bar Tools > Text (3rd up on list) and the Text (single line text) will open 
3. If the last command was either of the above a text input tool will open where the Exclusive Snap Toolbar is 

normally. That is to the right of the Pen Selection Tool bar, just above the Drawing Area.
4. In the Mtext or Text box window type X; making sure that it is a capital X.  In the height box and then OK at the 

bottom of the window.
5. In the drawing drag the X down below the Big Red Crosshairs (0,0 origin) and move it to the left of the crosshairs 

by about 50mm.
6. Left mouse click once and right mouse click twice.  The X is set in position.
7. Repeat step 1 or 2.  In the text box type Y  click OK.
8. In the drawing drag the Y to the left of the Big Red Crosshairs and up 50mm from the Crosshairs
9. Left mouse click once and right mouse click twice and the Y is set in position.
10. Press Save.

Now we are going to add some arrows reference text to this layer.

1. Go to Menu bar Tools > Dimensions (7th up on list) > Leader (last on flyout)
2. In order to place the arrow properly, we need to left mouse click once at the 30mm and move back to 0 and left 

mouse click again once and then right mouse once to make the arrows appear.
3. Do this with both X and Y coordinates.
4. You can now add numbers in the X and Y directions if you like; using the text box as before.  This completes our 

reference layer, at this time.
5. Click save icon (or shortform etc.) to save the layer or Template drawing, or use 'Save as' command.

1.4  Description of the Layer Window
Layers are useful to visualise entities that you want to see.  A layer can use different color of entities, lineweights or 
linetype.  If the color for layer 0 is white and you select yellow for entities then all entities will be yellow not white.

Imagine many sheets of clear plastic sheet with text written on one sheet, electrical on another, architectural on another 
etc..  By adding on subtracting the sheets visually so you can not see some of them you can see through the remaining 
stack of clear plastic sheets just what you want at any time.   We can also remove temporarily other information by 
switching off or freezing off entities by the color they were drawn in etc.

•    Lay 0 (zero) also called the multilayer insert layer is always present as default.  Its color is Black/White, its 
linetype is continuous and its lineweight is default (0.25mm).

•    To create a new layer you must give it a name, a color, a linetype and a lineweight before you can start drawing
on that layer.

• If you want existing entities to be on the new layer use the Menu Bar > Tools > Modify Properties or type 
command MP (modify Properties) to change the picked entities to the new layer once you have created it.

•       Layers have four states.  Layer States control visibility, regeneration, editability, and plotting.

A description of the icons shown in the Layer List window follows:

Icon Appearance Tool Tip Description Function

Eye open blue active Show All Layers Layer ON.  Thawed layer (default) visible in the 
drawing. When thawed layer is regenerated
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Icon Appearance Tool Tip Description Function

Eye not illuminated
blind not active

Hide all Layers Layer OFF.  Frozen layer is invisible and is not 
regenerated in the drawing.

Green Plus Symbol Add a new Layer Adds a new Layer, type in descriptive name

Green Minus Symbol Remove the current Layer Deletes current layer

Write Marker Modifies layer attributes / rename Set, color, width, linetype of a layer or rename

Other Layer Window Features:

Description Location Function

Layer Search Box Directly under Layer List title Type in a layer name to find 

Eye illuminated or not Within main Layer Window Shows  (ON) / Hides (OFF) the layer in the drawing.

Padlock illuminated or not Within main Layer Window
Unlocks or Locks a layer

Unlocked  (ON the default) are visible and can be edited.
Locked (OFF) are visible but cannot be edited.

Printer Symbol Within main Layer Window ON Prints the layer
OFF does not print this layer

Highlighted Active Layer Within main Layer Window Highlighted layer – The current layer you are working on.
Layer names without highlighting are not the current layer

Right Mouse click Within main Layer Window Brings up the following options described below

1.5  Results from within Layer Window
Right mouse click within the Layer window comes up with the following options:

•       Defreeze all Layers - 
• Freeze all Layers - 
• Add Layer – when title left mouse clicked opens Layer setting window
• Remove Layer – (window opens with warning saying “Layer 0 can never be removed”)
• Edit Layer Attributes -  when title left mouse clicked opens Layer setting window
• Toggle Layer Visibility -
• Toggle Layer Printing  - 
•       Toggle Construction Layer  - (refer to subsection Construction Layers above)

1.6  Alphabetical Order of Layers
Layers are displayed in Alphabetical order in  the layer list, and this does not relate to the order that entities appear in the 
z-axis of the drawing.  Each entity can be raised or lowered with respect to others, and each layer can contain entities that
are at different points on the z-axis.

Use the four Draw Order commands (under the Edit > Draw Order menu) to move entities up or down the z-axis.

Retrieved from “http://wiki.librecad/index.php?title=Layers&oldid=1834” on 22 June 2015, at 01:37.

HATCH

Commands: ha, hatch
Prompts:
In order to fill a border with hatch the shortest way is to select the entire contour (closed line, polyline) that needs to be 
filled with hatch.  Then click the relative icon then give confirm, finally choose the hatch and the scale and the hatch will 
be created.
An alternative is have hatch by clicking on the relative icon, click the relative on the Select > Deselect / invert selection > 
etc. hatches sub-menu, depending on the need, and give confirm, then select the hatch and the scale.  Scale and angle 
obviously will not work on solid fill.  You will need to experiment with the selection of hatch pattern scale and angle.  You 
may find it advantageous to form a chart to show standard hatch patterns at a selected scale and angle for each common 
drawing scale.  You could work with angle 0 degrees and scale 1.5 as a starting point with your experiments.

• Polylines are useful as hatch boundaries.  They can be deleted if necessary as one continuous line with a 
suitable color and/or conveniently placed on another layer, preferably non-printing.

• If hatch patterns not showing or a printing difficulty check that 'Draft' mode on the icon tool bar is not selected.
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MAKING HATCH PATTERNS

This subject may not assist many; reference material can be found below.
http://forum.librecad.org/Hatchpatternstudytd5714380.

SPLINES 

Splines may not be used by many and states this in the recommended mini-manual below
Retrieved from "http://wiki.librecad.org/index.php?title=Spline_tutorial_1&oldid=1665"
Categories: Usage Tools  This page was last modified on 26 April 2015, at 00:47.

CREATING YOUR OWN TEMPLATE 

LibreCAD Quick Start Guide/Creating Your Own Template.  Created by James Finnall in 28 August 2014 for use with LibreCAD 2.0 
last modified on 19 May 2015, at 01:53.  Slightly modified by present author.

 1.1 Templates
Simply stated templates are nothing more than than a simple drawing drawing file that especially contain various settings 
and components that can be used repetitively.  These settings can be as simple as the paper definition and unit 
specifications but can include layers, part or block devices and drawing elements like any other drawing.  These settings 
are however limited to the drawing only  Template drawings are unable to alter application preferences or other global 
settings within LibreCAD.

LibreCAD supports the use of a default template and the use of multiple templates.  A LibreCAD user that plans on using 
similar drawings may only require a single template. A user that plans on several different types of drawings may require 
multiple templates.  So a convenient location for your templates are within your drawing folder location.  This folder for 
drawings could be within your default Documents folder or a separate drawings folder or a part of a Projects folder as you 
may desire.  The idea here being to locate the drawing folder in an area where it is convenient to move freely back and 
forth from the storage locations. To use your current Documents folder would be convenient to include in a current backup
schedule easily as well.  Simply create a new folder called Drawings inside your Documents folder.  This location can be 
anywhere within your user permission level. Once a common area is created a template can be saved easily within the 
area or another folder for templates can be created as well to provide separation as desired for convenience.  A 
LibreCAD  user will also desire to create a folder for library symbols and Parts (Blocks) that is usually named “Library”.  
These should be created where the user has full write permission, probably inside their desired drawings folder.  The path
to this folder will be discussed in the next sub-section named Default Template. 

To create your first template start LibreCAD.  Select “Edit” on the top menu bar and then select “Current Drawing 
Preferences”.  On the first tab labelled “Paper” please select paper size and page mode (orientation) required.  Then 
select the “units” tab and set the actions as desired.  Proceed through all the tabs and set or skip the settings as desired.  
Please note the settings so that you know where and and can return to modify them as required in the future.  This could 
be by taking a series of screen shots in a file folder with the title Template setting Screenshots or similar.  Any changes 
here in the future will require the template to be updated again in order to maintain the new settings.  Once completed 
click the OK button to save the changes.

You may create other settings as desired or create and label layers, etc.  To save the currecnt settings as a template as a
template click on the “File” menu option on the top menu bar and then select “Save” or Save As”.  In the file dialog box 
please select your drawing folder and then enter a file name in the box directly below the folder contents.  The file type 
should be “Drawing Exchange 2007”.  Click the “Save” button to save the file.  If an existing file name is used you will be 
prompted to replace the file.

To use the newly created template select “File” from the top menu bar and then select “New From Template” option.  This
should start a new drawing using everything that was saved in the drawing.  Please note that at the top of the window that
the document is called “unnamed document”.  It does not use the filename of the template, only the contents of the 
template drawing.  You may use the new document as desired and then when saved you will be prompted for the folder 
location and filename.

 1.2  Default  Template

When LibreCAD is first executed it opens a default drawing.  This drawing can be specified as a template in the 
“Application Preferences” under the “Paths” tab.  Select “Edit” from the top menu bar and then “Application Preferences” 
followed by the “Paths” tab.  The last field listed is the “template” field.  This should contain the full path and filename of 
the desired template to use as a default.  The drawing specified here as a template will be used from three locations.  The
first is when LibreCAD is first executed and the default drawing is created.  The second is when “File > New” is selected.  
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The third is when the icon on the toolbar for “New “ is clicked.  Each time it will create a new drawing document.  Each of 
the new drawings can be selected from the “Window” option on the top menu bar if they have been created or any 
drawing that may have been opened.

In the “Paths” tab there are other file name to be specified.  The symbol or file folder location is called “Parts Library”.This 
folder specification should contain the full path and name of the folder mentioned earlier in regard to parts libraries.  The 
library folder can contain additional folders to categorise the items.  For instance: floor plan, electric, electronic, 
landscape, flow diagram, plumbing, hardware, etc.  The subfolders are required.  LibreCAD does not provide a 
mechanism to use the library directory.  A user could use it for template storage if they desired and then the templates 
could be used by the “New From Template” option or for the default template template setting.  The LibreCAD “Library 
Browser” will only present the created folders (and subfolders) with the drawings within the browser.

 1.3  Template Inclusions

The following inclusions imported on to the template are recommended, along with others specific to your type of drawing:

Layers:  A LibreCAD drawn chart including a list of horizontal lines each drawn to a named Layer, Color (line width) and 
Linetype.  The name of the layer, line width and linetype (also color number if not obvious) should be written alongside the
drawn line for easy identification.  Have list in alphabetical order in a systematic way.

Text:  Examples of the Fonts to be used set so the standard Heights, widths, color, layer, etc.  Have an example for each 
font height.  If you set text to a specific column width, have a rectangle drawn in the template to suit your commonly used 
scale e.g 1:100 or 1:50 scale.  Size of the column width and the height as you require

Symbols:  A set of the common symbols including Elevation and Section Markers; Detail Titles; North Points; Grid 
Bubbles scale bars etc that you will likely use in the new drawing.

Delete these unwanted template inclusions from your new drawing at drawing completion.

WIDGETS

 1.2 Moving and resizing Widgets
Toolbars and dock widgets can be dragged and dropped to the top, bottom, left or right of the main window.
Drag the left edge of a horizontal toolbar, or the top edge of a vertical toolbar.
Drag the title bar of a dock widget.
Widgets can also be resized by dragging their edges.

1.2  Dock Areas
Dock widgets (e.g. command line or layer list) can be moved and docked at the top, bottom, left or right.
You can now show and hide all the dock widgets in a specific dock area. You can also toggle the visibility of all floating 
dock widgets (those which are not currently docked).

1.3  Custom Widgets - Toolbar Creator
To create a new toolbar:
1. input the name
2. double click on an action to add it‐
3. drag and drop to arrange actions
4. press create

1.4  To edit an existing toolbar
1. select the toolbar from the drop down menu
2. double click to remove actions‐
3. drag and drop to arrange actions
4. press create

1.5  To delete an existing toolbar:
1. select the toolbar from the drop down menu
2. press destroy

1.6  To create a new toolbar – Menu Creator:
1. Input the name
2. double-click on the action to add it
3. drag and drop to arrange actions
4. press create
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1.7  To edit an existing menu:
1. select the menu from the drop down menu
2. double-click to remove actions
3. drag and drop to arrange actions
4. press update 

1.8  To update an existing menu:
1. select the menu from the drop down menu
2. double-click to remove actions
3. drag and drop to arrange actions
4. press update 

1.9  To assign a menu:
1. press assign
2. select the desired activator(s)
3. press save 

1.10  To remove assignment:
1. press assign
2. deselect the undesired activator(s)
3. press save 

1.11  To delete an existing menu:
1. select the menu from the drop down menu
2. press destroy

PRINTING - PLOTTING

1.1  Print Preview Command - Use

On the 'Print Preview' command there is a 'scale slider' that opens on the Tools > Options tool bar.
That is to the RHS of the Line Colour, Lineweight and Linetype modify tool bar;  2nd row of toolbars under the menu bar.  
Click on the scale you want from the list or manually type in the desired scale.

On the RHS of the 'slider scale' is a 'tick' box with the tool tip 'Print scale is locked to current value'.
When the box is 'unticked' the slider scale releases other scale option you can select.

Again on the RHS of the 'tick' box are three icons with the following tool tips:
• Toggle black/white mode
• Centre to page
• Fit to page

If you draw a frame of say metric A4 (accordingly scaled) around the drawing and then print on A4 sized paper you get 
approximately the right scale but not accurate.  To get the scale accurate you need to use Print Preview Mode.

• If the drawing comes out very small on an otherwise empty sheet it is because a tiny element or 'junk' is 
accidently left somewhere outside the area around the drawing.  Search for it and delete it. 

• In the Print Preview there is no “Fit to Page” button”.  Uncheck the “fixed” check box.
• I clicked on the “Print Preview” button but how can I leave the print preview mode without printing?  Turn off “Print

Preview” mode.  Hit the “Print Preview” button or uncheck “File > “Print Preview”.
• Re-pressing the 'Print Preview button will return you to Model space (drawing area).
• Refer to the subsection Printing Difficulties below

1.2  Print Command - Limitations
In the simple 'Print' command there is no scale setting.  It fits to page with no arbitrary scale.

If you draw a frame of say metric A4 (accordingly scaled) around the drawing and then print on A4 sized paper you get 
approximately the right scale but not accurate.  To get the scale accurate you need to use Print Preview Mode.

• If the drawing comes out very small on an otherwise empty sheet it is because a tiny element or 'junk' is 
accidently left somewhere outside the area around the drawing.  Search for it and delete it. 

1.3  Printing - Position Centred and to Scale
Draw the border centred within the finished page, or this will not work.  
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For example using a 10” x7.5” border, which is half an inch within a USA “letter size” page.
There must be nothing outside the border., or LibreCAD will use it to centre the page, rather than the border.
Select Print Preview.  This will produce a preview centred to the page. And scaled so that the border is as large as 
possible.
Set the scale and check “fixed”.
Press the centre button.  This positions the drawing, and may also apply the scale factor.
Print.

Saving the border may be useful (wasn't tried) for producing multiple pages with a uniform format.
• I tried to print a scale drawing that I know fits within an A4 piece of paper as I have had it printed out at a print 

shop, but when printed it comes out very small, about 3cm x 3cm. How to print to scale or to adjust the size of the
print out?

If you want to print in A4, go to Options> Current Drawing Preferences> Paper, and set A4.
Then open 'Print Preview' (select the appropiate Printer image icon) and set the desired scale (a window box opens to the
right of the three line colour, line width and linetype set windows)  Type in the desired scale. Move the paper to the 
wanted position with the hand symbol (mouse), or 'center to page' might also work if there is a frame around the drawing. 
Then go to 'print', set A4 in your printer's driver settings box if it's not already, and print.  Always use print preview, only in 
this way can the outcome can be controlled.

1.4  Printing as PDF
Menu Bar > File > Export > Export as PDF (on flyout)

1.5  Printing Challenges
• To remove 'space junk' use command autozoom.  Double click on middle mouse button or scrollwheel; this will 

get to the drawings extents.  Examine the area around the perimeter of the screen to find the unwanted 
geometry and remove after checking no layer off or frozen.

• If the drawing is not near or associated with the origin (0,0) move it.
• Copy your drawing contents to another new drawing by opening both in parallel so you can tab between them. 

Select objects in source, press Ctrl+C, define reference point, change to target drawing or to a border 
template drawing, press Ctrl+V, define insertion point.

• If unable to print try printing as PDF as explained above.  Ensure you have unticked box in printing drop down 
'Print to file'.

• Try "File / Print Preview", and adjust scaling, centre, etc. Second, try File / Export Export as PDF, if you still have 
problem with File/Print. If you still have issues there, please upload a test case in dxf format to forum.

• If you have a rectangle set to a non-print layer to show the viewport size of a plot; remember to left mouse click 
on it and check the size in the status area at the bottom of the LHS of the screen.

• If you want your drawing to fit on the page automatically and don't mind what aspect ratio it is printed, you can 
just press the Print button.

• Make sure you have set the paper format at Edit > Current Drawing Preferences > Paper tab.  Here set the 
'Paper Format' to A4 size, for instance.

• If your drawing has to be on an exact position you can draw a white (as printing white on white paper will make 
things disappear) rectangle, of the same size as your paper, around your drawing and selecting 'Fit to 

page' in the 'Print Preview'.
• For more elaborate printing you should use the 'Print Preview' button (or File > Print Preview).  Here you can set 

the aspect ratio you would like and centre the drawing to the page.  Sometimes you want your drawing to 
be at a specific position.  The position of your drawing can be changed by clicking on the page (the white 
rectangle around your drawing) and moving it around.

IMPORT DRAWINGS OR IMAGE
 1.1 DWG to DXF File Format
Obtain the free " Any dwg dxf converter ", or similar to convert file.

1.2  Import Image and Scale (bmp or png)
Problem importing image (bmp or png) as scale unknown. 300 DPI image

LibreCAD does not manipulate DPI directly. If you want to modify the relative size of the imported image: try the main 
menu: Modify >Scale.  There's drawing scale and printing scale, and it helps to do printer preview

At what DPI the image is imported?
It is imported with one unit per pixel. So for instance an image of 900x600 pixels will be in a drawing with meter set as unit
(edit current drawing units) 900x600 meters. If you know with what dpi the image was scanned you can calculate the 
scaling factor you have to apply after importing. Or if you know an the real live size of something in the image, you can 
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measure that in the drawing (info distance point to point) and then calculate the necessary scaling factor to get it to the 
right size.  Example:  If image is 300DPI just need to resize to 0.08466% and get correct size.

1.3  Import object drawn on Graph Paper
Is there a way to match the 1cm on the graph paper to the 1cm in LibreCAD?

You have to scale the imported object on the image to the need size.  Measure  a known distance on the graph paper 
image (as large a distance as possible for greater accuracy) with the measuring tool with Free Snap on.  This is so that it 
does not snap to any other other objects or image corners.  Calculate the needed factor to get the right size and scale the
image with Modify – Scale.  After scaling the the scaled image will appear to disappear.  You may have to perform an 
“Auto-Zoom” to bring it back.
  

• If you know an overall dimension of the object in 'real life', draw this dimension length on screen, and then insert 
and scale the object proportionally from the the start of this dimension to the end of the dimension. You then have
the length and width.

• By default an image is imported with one unit per pixel.  Scanners and optical lenses produce distortions, so there
will always be some inaccuracy.  A bitmap-image does not have a physical size. Some carry an optional dpi 
value.  If possible set the dpi etc in the boxs that opens to the right hand side of the three set colour, linewidth and
linetype boxes (For me the EX Exclusive Snap Mode Tool bar location).  Middle Points 1; Angle 0.0; Factor 1; 
DPI 25.4 or whatever.

IMPORT MAP TO MEASURE AREA

Given with scale.  Eg. map source Openstreetmap (http://www.openstreetmap.org)
• Create new layer
• “Draw / insert image”
• Measure scale bar on map : 500 m (scale) equals 83.6 units in LibreCAD using command “Dimension / horizontal

Solution 1: Rescale your Measurements
• 1 unit in LibreCAD = 5.98 m (500 / 83.6)
• If you measure areas: 1 unit^2 = 5.98 * 5.98m^2
• After measuring convert units into meter.

Solution @: Rescale your image
• Select the layer where the image was imported
• 500 m are 83.6 units.  If you prefer “500 m = 50 units” rescale image by: 50/83.6 = 0.598
• “Modify / properties” and click the image (remember you should have selected the right layer).
• The property menu opens.  Select entry “scale”, change default value “1” by “0.598”
• “Info / Pologon area” and click around the picture object that you want the area of; e.g. a meadow.
• The more points you click the more precise the measurement may be.

In our example we got an area of 7116 units^2.  1 unit = 10 m, so 1 unit^2 = 100m^2.
7116 units^2 = 7116 * 100 m^2 = 7116 m2 = 70 ha.

Quick control: the longer size of the rectangle has a size of about 1000m, the shorter of more than 500m, why 70ha 
should be about the right dimension.  

Retreived from “http://wiki.librecad.ord/index.php?title=Measure _Areas&oldid=1655” 

EXPORT DRAWINGS OR IMAGE

 1.1 Difficulties
In .jpg Format lineweight can appear thin.  Difficult to completely control the result of “export as image”  recommended to 
make a pdf of the plan first.  Go into print preview and make you setting as if you want to print to paper (don't forget to set 
the proper paper size in “current drawing preferences”.  Stay in print preview and “export as pdf”.  In an other software like
inkscape or pdf-xchange viewer you can then convert the whole sheet to an image of desired resolution, about 300 dpi 
and png as format recommended.
In an image editing app like Irfanview or xnview you can cut out any part of the whole if needed.  Do not choose line 
thickness with visibility in the jpg in mind, but use standards as used for paper drawings.  That's roughly 0.25 mm for 
normal object lines, 0.5 mm for the outline of cut parts and maybe 0.12 mm or 0.18 mm for auxiliary lines, 0.35mm may 
be used for dashed axis lines.
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If "export as image" does not work, and generates a zero lengths file when you want a png with 300dpi resolution.  In  
experiments some have found out with resulting pixel size over about 10000x10000 or 12000x8000 you get those 0 byte 
files. So try a lower resolution or smaller "paper size". Or transform the pdf to pixels in an external program.

When importing a jpg to use as a layer and this layer is visible, or visible and not editable, you may find difficulty in 
modifying objects on other layers.  As a workaround try making the jpg layer invisible and then then you can select and 
modify other objects.  This is because the image layer hides other objects for the selection tool.

PDF
Why does exporting a PDF produce a blank page?

1. Need to select a paper format (e.g. A4 in 'Current Drawing Preferences'.
2. After Current Drawing Preferences to change paper size, File > Save is needed;
3. File > Print preview;
4. File > Export> Export As PDF

TROUBLESHOOTING
1. “My drawing had some hatches but now I cannot see them anymore.”
2.  Turn off the draft mode. “View” > “Draft”
3. “I can move my curser only horizontally/vertically”

 Turn off “Restrict Horizontal” or “Restrict Vertical”
 “Snap” > “Restrict Horizontal” or Snap > “Restrict Vertical”

4. “In the Print Preview there is no “Fit to Page” button”.
Uncheck the “fixed” check box.

5. “I clicked on the “Print Preview” button but how can I leave the print preview mode without printing?” Turn off 
“Print Preview” mode.  Hit the “Print Preview” button or uncheck “File > “Print Preview”.

6. “While working on my drawing I can't find some changes to the drawing?”
Make sure the layer, where you applied the changes, is set to visible.

7. “I ruined my file by saving and empty drawing over it, what can I do?”
 There is a chance that in the directory where your file was saved there is a file starting with “#”, for example 
“#myfile.dxf”.  Just duplicate this file (copy and paste) and rename it as you like.

8. “I was told to use a command I can't find in the toolbars.”
 This command may be implemented as a plugin and be only be available in the main menu.

9. “I miss a feature that I would like in LibreCAD.  I just implemented a solution.  I have a difficulty that is not listed 
nor can be found in the manual.  What do I do?
 Advise the LibreCAD forum.

10. If hatch patterns not showing or a printing difficulty check that 'Draft' mode on the icon tool bar is not selected.

TO PRINT SCREEN – for inserting illustrations in this documentation

With LibreCAD program running, that is open to the start page, navigate to the menu bar Options/Application 
Preferences/Appearance tab.  In the right hand section of the open window in the section named Graphic Colours change
Background colour in the input box to White by typing #FFFFF.  The usual Background colour is Black with the number 
#00000.  White is easier to read and reduces toner use.  Change the Background colour back to its original setting after 
taking the screenshots. 
A screenshot is taken by zooming in so that there is a minimum of unnecessary clutter surrounding what you want on the 
screenshot (either in LibreCAD or other program) press the Window keyboard key (RHS of Left Ctrl key) and with key 
depressed press the Print screen/SysRq keyboard key (RHS of F12 key on top row of keyboard).  A 'photo-flash' will be 
seen showing that the screenshot has been taken.

Go to the document that you want to insert the screenshot, place the curser where you want the illustration to be.  Use the
Enter key to move text down to allow space for inserted illustration.  Then locate the document curser where you want the
top left-hand corner of the illustration to be and right-click the mouse and select the Paste button. Save.  You can now 
fine-tune the size and location of the illustration.

VIDEO – Downloading and Viewing

You can either click the Youtube icon on the desktop or open Google Chrome and type Youtube video LibreCAD 
download.  When using Win-X Youtube Downloader (icon on home page) find the video you want on the internet.  To 
obtain video type the subject into Google with the word video.  When found, let it play for a few seconds then using 
mouse right click copy the video address from the window near the top of the screen, minimise the window for a moment 
or close it to save extra date charges and open Win-X Youtube Downloader by double clicking on the Home Page icon.  
Paste the copied address obtained from the internet and press the analyse button and after a few seconds a list of 
download options are shown.  Select the quality you want (360) has been adequate generally but make sure you choose 
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MP4 format or the download may not work on your computer.  Save the video in the C:Video directory in a Folder you 
make titled the general subject, so easily found in the future.  Watch the video whenever you want now, without any 
additional charges. 

If having difficulty getting the video to play open location with 321 MPC-HC x64 icon or DVD Cyberlink icon on my 
desktop.

SCANNING

Drivers for HP Deskjet 2050 obtained from www.hp.com/support/australia.  This is loaded on Windows 8.1 computer.  

SPELL CHECK DICTIONARY 
 
To spell check drawing notes open the notes of Mtext or single line Text, highlight the notes; right mouse click and copy 
and Paste (right click and Paste) into a program such as OpenOffice Writer.  Now you can use the Spelling and Grammar 
tool found at the Menu bar > Tools > Spelling and Grammar to spell check the notes.  Unknown words can be added to 
the custom dictionary.  Copy and paste, using the Copy and Past commands as before; to place the corrected notes back
into the Mtext or Text in your drawing.  

This Apache OpenOffice Writer document has been spell-checked in English (Australia); change this setting if you desire. 
Refer to section How to modify the LibreCAD User Extensive Manual.

If a word in this manual is underlined in red, this word can be checked by right mouse clicking with the curser on the 
questionable word and click Add ► Standard Dic (Dictionary) if you are sure the word is spelled correctly and you accept 
the word OR choose ABC Spelling and Grammar for other options. 

ADOBE READER

"C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe"
On desktop.
Used to read material as saved as PDF.   You may need to download this, refer below. 
When Adobe Reader PDF program opens initially Go to Edit  Menu → Preferences (Categories column) → Fit Width 
Documents (LH Column).  Look to first line and tick box titled 'Restore last view settings when reopening documents'.   
OK and close.

When you view a new document initially Go to the View menu → Zoom → Fit width and when you close, the appearance 
settings will be saved so that when reopened it will look the same as it was left.

If you get to a document page view without any Options or Menu Rule bar, press the keyboard Esc key and it will take 
back to the normal appearance.

SAVING ITEMS FROM THE WEB AS PDF FILES. 

"C:\Program Files\PDFCreator\PDFCreator.exe" 
On Desktop (icon has Flame Symbol)
Procedure used in saving pages such as from a website:
 
Download a free PDF Creator program such as PDF Creator.Ink.  Locate program (C  opy from Downloads area) to 
Programs area (generally part of the C: Documents area) and add a icon on the Desktop.

Open the Internet to the site you want to keep of; right click → Print and the Print window will cover the screen.  There is a
large PRINT button but ignore this for the moment.  Look about a third of the way down the page until you see Print 
Destination set this to PDF Creator.  Now Press the large PRINT button.  In a moment a Warning notice come on screen 
saying 'The Printer Requires Attention'.  Click on the notice (it will disappear) and your Desktop page will appear without 
having to minimise your present open programs.  The Forge PDF Creator page will be visible and you can check the file 
name is the way you want it and make some other adjustments.  When satisfied, press the right hand circle saying SAVE.

Check that the material has been saved as required by following the section above under the header Adobe Reader. 

Now go to the next page you want to keep and repeat the procedure in the paragraph above, except that the Print 
Destination, in the print window will likely remain as set as PDF Creator and if it does you can proceed with pressing the 
PRINT button and the warning sign will come and you proceed as before. 
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KNITTING PATTERNS

The lessons which may have other applications are in PDF format and because they are to big for the Wiki, please find 
them in Harry's Box.com area (https://app.box.com/s/i0cv6gvgbwlspqnd3pux/1/1128879663).
Retrieved from "http://wiki.librecad.org/index.php?title=HowTos_and_Guides&oldid=1487"

HOW TO MODIFY THE LibreCAD USERS MANUAL

This document is formatted on Apache Open Office Writer and assumes a limited knowledge of word processing 
programs. It may be Saved As into Word format but may need some reformating.

As far as possible try to use the Format Paintbrush to maintain your document the way you desire.

Word Finder:  To find a word in this document click on the 'binoculars' icon (on tool icons below the Menu bar) with the 
tool-tip  'Find and Replace' (Ctrl+F) type a word in the Search for pane and click on the Find radio button.   A small 
window opens asking basically 'do you want to continue' if you click on 'yes' button the 'Find and Replace' window opens. 
Now every time you press the 'Find' button it will open to the next usage of the word in the document.

Section Heading:  When adding section headings it is suggested that you select by highlighting an existing title, right 
click Copy and after clearing away some text in the location you choose (by pressing the enter key a few times)  right click
again and Paste.  Titles like the one to this section are called Heading 1 In the Apply Style box (located on the left hand 
side just above the Ruler.  

Subsection titles are called Heading 2 in the same location as Section Headings.  You can reset the numbering to 
subsection Heading 2 titles by locating the curser over the title, right mouse click and Restart Numbering is the 2nd item 
down on the flyout.  
When copying subsections titles, to add another subsection, do not copy the initial subsection number just the title and 
when you paste the copy the appropriate subsection number will be inserted with the title and all you have to do is change
the title name.

Small Bullets ( ▫ ) have been chosen from the Menu bar > Formate > Bullets and Numbering > smallest type available. 

Font is Arial size 10.

Updating Contents Page  is simple, if you have followed the previous paragraphs.  Use the Navigator (a desciption of 
its use follows) or scroll carefully to return to the Contents pages place the curser over the text, right click and a flyout will 
appear you want to click on Update Index/Table (10th one up up from the bottom of the flyout list)  Ensure you choose the 
right name.  The Contents page will update.  Spacing errors may be changeable from the contents page, experiment.

Go To Selected Section by Page To be taken to a numbered page of this document:  Position your curser over the page
number in the Contents Section (on page 1 onward).  Use keyboard shortform Ctrl and then  left mouse click when the
curser changes into 'hand symbol'.  The document will open to the required page of the this document.  

Navigator:
To navigate around this document: press the F5 key (generally in the top row of the keyboard) OR the small 'compass' 
icon (alongside the 'binoculars' icon) on the tool bar under the Menu bar and a small window opens.  
This window can be moved (dragged) on to a little used part of your screen for future use.  Repeat the F5 key command 
to remove the active window from view.  In the small window if you double left mouse click on Headings Contents 
Section this document will go to that location (or any other section you double click on) after you scroll down and find its 
location. Or you can scroll down using the scroll bars in the auxiliary window until you find the section you are after and 
then double click that section heading.
Change field name at the end of this document
Place curser over the field name, right mouse click, choose Fields, select alternate desired field and OK. 

Spell-Checker:  
If a word is underlined in red this word can be checked by right mouse clicked and click Add ► Standard Dic (Dictionary) 
if you are sure the word is spelled correctly and you accept the word OR choose ABC Spelling and Grammar for other 
options. 

This Apache OpenOffice Writer document has been spell-checked in English (Australia); change this setting if you desire. 
To change language and with Apache OpenOffice Writer open on screen go to Menu bar > Tools > Language ► (flyout) 
For All Text (or check other options here) ► (flyout) and (click on your preferred language).  
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You may want to change language settings to ensure the Spell-Checker does question every word with red underlining. 
word..  Check settings by going to Apache Open Office Menu tools > Language > For all text > More (last on list) and the 
Options – Language Settings – Languages window opens.  Here currently User Interface reads: English (UK) further 
down the Local Setting: Default – English (Australia) and again further down Default Languages for Documents: Western 
ABC Default – English (Australia).   The check box is currently un-checked and some minor setting like Australia dollars 
appear to be correct. 

Other Format Questions
Consider the sections toward the end of the Contents page for more information.  Perhaps your query may be answered 
in the sections there or in the Help section of the word processing program (or other program) that you are using.

LibreCAD_Users_Manual_by_Nigel_Vincent.odt
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